Opened 7 years ago

Closed 7 years ago

#258 closed defect (fixed)

Attrib 198 (Uncorrectable_Sector_Ct) incorrectly decoded on Sandforce SSD's

Reported by: stevenhartland Owned by: Christian Franke
Priority: major Milestone: Release 6.1
Component: drivedb Version: 6.0
Keywords: Cc: liv3d

Description

It seems like attrib 198 (Uncorrectable_Sector_Ct) is being incorrectly decoded on Sandforce SSD's.

Most manufactures of these drives don't implement attrib 198 but Kingston E100 series do and this causes smartd to report errors due to increasing "Offline uncorrectable sectors".

On these disks this attrib is "Uncorrectable sector count relative to the number of sectors read this power cycle." so its not a pure error count and hence should not be treated as such.

The details on how to decode the attrib values can be found here:-
http://media.kingston.com/support/downloads/MKP_306_SMART_attribute.pdf

Attachments (3)

output.txt (8.2 KB) - added by stevenhartland 7 years ago.
output.2.txt (2.5 KB) - added by stevenhartland 7 years ago.
README (1.8 KB) - added by slavon888 6 years ago.
http://smartmilhealth.com

Download all attachments as: .zip

Change History (12)

comment:1 in reply to:  description Changed 7 years ago by Christian Franke

Component: alldrivedb
Milestone: Release 6.1
Owner: changed from somebody to Christian Franke
Status: newaccepted

Most manufactures of these drives don't implement attrib 198 but Kingston E100 series do and this causes smartd to report errors due to increasing "Offline uncorrectable sectors".

This should not happen if the drive is detected by drive database because the SandForce entry already contains a definition for attribute 198. As a side effect, this disables the interpretation of this attribute as "Offline uncorrectable sectors" (same as "-U 0" directive).

Please attach a "smartctl -x ... " output for the affected drive.

Changed 7 years ago by stevenhartland

Attachment: output.txt added

comment:2 Changed 7 years ago by stevenhartland

It is detected by the DB by:-
"KINGSTON (SV300|SKC100|SE100)S3.*G|" other SF-2281

It does seem like 198 is listed there though:-
"-v 198,raw48,Uncorrectable_Sector_Ct "

Attaching file for -x and -P show

Changed 7 years ago by stevenhartland

Attachment: output.2.txt added

comment:3 Changed 7 years ago by liv3d

Cc: liv3d added

comment:4 in reply to:  2 Changed 7 years ago by Christian Franke

It does seem like 198 is listed there though:-
"-v 198,raw48,Uncorrectable_Sector_Ct "

The problem with smartd should not appear if this setting is effective.

The print format is actually hex48 instead of raw48, see drivedb.h. This is unchanged since this was added in r3168.

Do you use a modified drivedb.h or a local /etc/smartd_drivedb.h ?

Try using "-v 198,raw24/raw32,Uncorrectable_Sector_Ct " and examine the RAW value printed by smartctl.

comment:5 Changed 7 years ago by stevenhartland

hex48 we changed to raw48 to just look at the value it was hex48 originally and smartd was reporting the errors.

With raw24/raw32 we see:-
198 Uncorrectable_Sector_Ct 0x0010 100 100 000 Old_age Offline - 3749088/0

comment:6 Changed 7 years ago by Christian Franke

This attribute uses the opposite order of COUNT and TOTAL fields.
The option "-v 189,raw24/raw32:210zr54,Uncorrectable_Sector_Ct" could be used to get COUNT/TOTAL output like with attribute 9 and 195.

Regarding smartd: Does smartd actually print warnings for attribute 198 even if option "-v 198,..." is effective? If yes, please provide the following info as attachments:

  • an example warning from syslog, and
  • the /etc/smartd.conf file, and
  • output from "smartd -q onecheck".

comment:7 Changed 7 years ago by stevenhartland

I assume you mean the following for the db entry? (198 not 189 and trailing space)
"-v 198,raw24/raw32:210zr54,Uncorrectable_Sector_Ct "

Which leads to the following output:-
198 Uncorrectable_Sector_Ct 0x0010 105 105 000 Old_age Offline - 0/11392505

Not had any warnings from smartd since correcting the entry :)

Given this solves Is the change to this entry something that can be committed to the drivedb.h so update-smart-drivedb can automatically?

comment:8 Changed 7 years ago by Christian Franke

The format change is unreleated to the smartd warning. Any "-v 198,..." setting should suppress the warning as a side effect. Please retest with the original drivedb.h: remove possible /etc/smartd_drivedb.h and run /usr/sbin/update-smartd-drivedb. If the warning reappears then, provide the info described above.

comment:9 Changed 7 years ago by Christian Franke

Resolution: fixed
Status: acceptedclosed

Print format fixed in r3789, r3790.

Problem with bogus smartd warnings could not be reproduced.

Changed 6 years ago by slavon888

Attachment: README added
Note: See TracTickets for help on using tickets.