Opened 14 years ago

Closed 14 years ago

#95 closed enhancement (fixed)

JMicron 4 device support (0x152d:0x0551)

Reported by: cheetah Owned by: Christian Franke
Priority: minor Milestone: Release 5.40
Component: all Version: 5.39.1
Keywords: jmicron Cc:


I've recently acquired a 4 bay USB3+eSATA enclosure, specifically this one: (Mediasonic Pro Box 4 Bay Enclosure USB 3.0 & eSATA [HF2-SU3S2] in case the link becomes dead). NB: I'm not actually using USB3 (yet), it's connected to a USB2 host.

The enclosure uses a JMicron chip that smartmontools does not support. I'm hoping that JMicron implemented this one similarly to the two device chips, and that smartmontools can support this without huge effort.

What smartctl says when I try to query it: "... Unknown USB bridge [0x152d:0x0551 (0x100)]" ... <please use -d>

On a lark, I tried the usbjmicron,0, and that appeared to successfully give the info for the first disk. So I tried usbjmicron,1 for the second device, and that I think made the enclosure "reboot": I got a usb disconnect, and then it came back to life.

Change History (5)

comment:1 by Christian Franke, 14 years ago

Component: smartctlall
Keywords: jmicron added

The parameter of the -d usbjmicron,PORT option selects the port for USB bridges with two ports (typically IDE+SATA or 2xSATA). This device likely uses a 4x SATA port multiplier chip connected to a bridge with one port.

How are the 4 drives addressed by the kernel on the SCSI command level: 4 SCSI IDs or one ID and 4 LUNs ?

Did you try the /dev/sdX names of all 4 devices?

comment:2 by cheetah, 14 years ago

In my first attempt, I'd only tried -d usbjmicron,0 with the first drive and -d usbjmicron,1 with the second drive (which caused the error) and stopped there. I did some more testing, and found that if I use -d usbjmicron,0 with each drive, that appears to work properly.

Your guess about the SATA port multiplier jives with the product documentation, which mentions that your SATA controller must support the port multiplier feature in order to use the box with eSATA.

If I'm reading the info in /sys correctly, it shows up as one SCSI ID with 4 LUNs. Right now I have /sys/bus/scsi/devices/host40/target40:0:0/, and within that 40:0:0:0 through 40:0:0:3, and within each of those one block/sdX, in total corresponding the four drives in the unit.

comment:3 by Christian Franke, 14 years ago

Milestone: Release 5.40
Owner: changed from somebody to Christian Franke
Status: newaccepted

Does it work without PORT parameter and with 48-bit ATA commands enabled?

smartctl -d usbjmicron,x -x /dev/sdX

If the above provides reasonable output, the device could be added to the table of known USB IDs. The -d option would no longer be necessary then.

in reply to:  3 comment:4 by cheetah, 14 years ago

Replying to chrfranke:

Does it work without PORT parameter and with 48-bit ATA commands enabled?

Yes it does. No errors, and all output looks to be coming from the correct disk AFAICT.

comment:5 by Christian Franke, 14 years ago

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.