Opened 5 years ago

Closed 5 years ago

#545 closed enhancement (fixed)

Crucial MX200 SSDs drivedb.h regexp

Reported by: R00kie Owned by: Christian Franke
Priority: trivial Milestone: Release 6.4
Component: drivedb Version: 6.3
Keywords: Cc:

Description

I believe I may have found a glitch with the regexp used to identify Crucial's MX200 line of SSDs.

According to the information on Crucial's website and what my MX200 identifies itself with, the regexp probably needs to be corrected.

The regexp should have 250|500|1000 instead of 256|512|1024.

Attachments (2)

mx200regex.patch (786 bytes) - added by R00kie 5 years ago.
Regexp correction patch
MX200_smartctlx (11.3 KB) - added by R00kie 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by R00kie

Attachment: mx200regex.patch added

Regexp correction patch

comment:1 Changed 5 years ago by Christian Franke

Milestone: Release 6.4
Owner: set to Christian Franke
Status: newaccepted
Type: defectenhancement

Please attach a sample smartctl -x output of such a drive.

The entry added in r4042 is IMO correct but probably incomplete. It was based on a sample output from an actual Crucial_CT1024MX200SSD1 (see database mailing list).

comment:2 Changed 5 years ago by R00kie

Version: 6.3

The reason that led me to suspect the regex might not be correct, is that of all the MX200 SSDs currently listed on MX200 series pdf flyer[1], none of them match "Crucial_CT(256|512|1024)MX200SSD[1346]".

In this case I suppose an entry for the (250|500|1000) models should be added to the regex list instead of modifying the existing one.

I'm attaching the output of 'smartctl -q noserial -x' of my MX200. Note that I have changed the regex in the drivedb.h that I'm using, so smartctl does not say that the drive is not in the database.

I have confirmed that the attribute id/names match with the information provided in the pdf linked in the database mailing list.

[1] http://www.crucial.com/wcsstore/CrucialSAS/pdf/product-flyer/crucial-mx200-ssd-product-flyer-letter-en.pdf

Changed 5 years ago by R00kie

Attachment: MX200_smartctlx added

comment:3 Changed 5 years ago by Christian Franke

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.