Opened 18 months ago

Closed 11 months ago

Last modified 6 weeks ago

#977 closed enhancement (fixed)

Please add Crucial MX500 to the database

Reported by: Cmdr_Zod Owned by: Christian Franke
Priority: minor Milestone: Release 7.0
Component: drivedb Version: 6.6
Keywords: Cc: Holger Weiß

Description

Please find attached the output of smartctl -q noserial -x /dev/sdX
According to press reviews, the MX500 uses Silicon Motion SM2258

Attachments (5)

smartctl-CRUCIAL-MX500.txt (10.8 KB) - added by Cmdr_Zod 18 months ago.
mx500.jpg (61.9 KB) - added by sporkman 14 months ago.
SMART mappings
smartctl-CT1000MX500SSD1.txt (13.5 KB) - added by bobmsea 12 months ago.
smartctl_a_ct1000.sh (500 bytes) - added by bobmsea 12 months ago.
Decode new values for the Cruicial CT1000MX500SSD1, while waiting for the smartmon database to be updated
mx500.txt (14.3 KB) - added by Sorin Sbarnea 6 weeks ago.

Download all attachments as: .zip

Change History (18)

Changed 18 months ago by Cmdr_Zod

Attachment: smartctl-CRUCIAL-MX500.txt added

comment:1 Changed 18 months ago by Christian Franke

Milestone: Release 6.7

... Silicon Motion SM2258

Related: BX300, ticket #963.

comment:2 Changed 18 months ago by Christian Franke

Tickets #994 (1TB), #995 (500GB) and #1004 (2TB) have been marked as duplicates of this ticket.

Last edited 17 months ago by Christian Franke (previous) (diff)

comment:3 Changed 17 months ago by Christian Franke

Ticket #1024 (250GB) has been marked as a duplicate of this ticket.

comment:4 Changed 14 months ago by sporkman

Attached is a screenshot from Crucial's windows tool that shows some of the SMART ID mappings. From this thread in Crucial's support forums: https://forums.crucial.com/t5/Crucial-SSDs/MX500-SMART-parameters/m-p/184298/highlight/false#M55906

Changed 14 months ago by sporkman

Attachment: mx500.jpg added

SMART mappings

comment:5 Changed 14 months ago by Holger Weiß

Cc: Holger Weiß added

comment:6 Changed 13 months ago by Antony

Please add for version 5.43 as well (sorry I'm not sure if this is done by default)

As it stands (on RHEL 6.9), smartmontools e-mails every few days (for both drives in a RAID mirrored array) with:

The following warning/error was logged by the smartd daemon:
Device: /dev/sda [SAT], 1 Currently unreadable (pending) sectors

(or /dev/sdb)...but when I check manually, the "197 Current_Pending_Sector" shows zero maybe it returned to zero).

As noted by Ben B (I have the same issue):
https://listi.jpberlin.de/pipermail/smartmontools-database/2018-April/000176.html
"Note that one was originally displaying the warning about log count not
agreeing with the log buffer, and that both cause smartd to generate
occasional (every few day) warnings about "1 Currently unreadable (pending)
sectors" (which is what prompted me to dig in the first place). I suspect
the firmware isn't 100% correct."

In my RHEL 6.9 system, smartctl reports:

[sda] Warning: ATA error count 0 inconsistent with error log pointer 1

[sdb] Warning: ATA error count 0 inconsistent with error log pointer 2

Not sure how much of this is related to smartmontools and how much is Crucial firmware... Currently running M3CR020 firmware, will update to M3CR022 and see how things go.

Thanks, Antony.

Changed 12 months ago by bobmsea

Changed 12 months ago by bobmsea

Attachment: smartctl_a_ct1000.sh added

Decode new values for the Cruicial CT1000MX500SSD1, while waiting for the smartmon database to be updated

comment:7 Changed 11 months ago by Christian Franke

Owner: set to Christian Franke
Status: newaccepted

comment:8 Changed 11 months ago by Christian Franke

Resolution: fixed
Status: acceptedclosed

comment:9 Changed 9 months ago by Christian Franke

Ticket #1130 has been marked as a duplicate of this ticket.

comment:10 Changed 8 months ago by Christian Franke

Milestone: Release 6.7Release 7.0

Milestone renamed

comment:11 Changed 3 months ago by Christian Franke

Ticket #1196 has been marked as a duplicate of this ticket.

Changed 6 weeks ago by Sorin Sbarnea

Attachment: mx500.txt added

comment:12 Changed 6 weeks ago by Sorin Sbarnea

I am afraid that this bug is not fixed. Even the latest firmware from Crucial (M3CR023) does not address the random reporting of a single unreadable sector.

comment:13 Changed 6 weeks ago by Christian Franke

I don't see any random reporting of a single unreadable sector in mx500.txt. BTW: If this only appears in the legacy SMART Error log, try smartctl -x -a ... to add legacy logs to the output.

Hiding a firmware bug would possibly require some clever heuristics or a new -F, --firmwarebug option. Feel free to propose this via a new ticket.

Don't reopen this ticket as it solely addresses the addition of MX500 to drive database.

Note: See TracTickets for help on using tickets.