Opened 2 years ago

Closed 18 months ago

#816 closed enhancement (fixed)

ST4000LM024: Runtime_Bad_Block should be SATA_Downshift_Error_Count

Reported by: guanx Owned by:
Priority: minor Milestone: Release 6.6
Component: drivedb Version: 6.5
Keywords: Cc:

Description

Newer (since early 2017) "Seagate Expansion Portable 4TB" hard disks with model number ST4000LM024 instead of the old ST4000LM016 have the SMART 183 (0xB7) attribute, which is displayed as Runtime_Bad_Block by smartctl. However, the value of this attribute increases with the downshift of SATA link speed, e.g. from 6Gbps to 3Gbps shown in dmesg as "limiting SATA link speed to 3.0 Gbps". The same feature is probably also present in other STx000LM024 models.

Attachments (1)

ST4000LM024.log (14.7 KB) - added by guanx 2 years ago.
"smartctl -x" output

Download all attachments as: .zip

Change History (7)

comment:1 Changed 2 years ago by Christian Franke

Milestone: Release 6.6undecided
Type: defectenhancement

Please provide a sample smartctl -x output for an affected device.

PS: Please do not set the Milestone in future submissions.

Changed 2 years ago by guanx

Attachment: ST4000LM024.log added

"smartctl -x" output

comment:2 Changed 2 years ago by Christian Franke

Milestone: undecidedRelease 6.6
Summary: Seagate: Runtime_Bad_Block should be SATA_Downshift_Error_CountST4000LM024: Runtime_Bad_Block should be SATA_Downshift_Error_Count

comment:3 Changed 19 months ago by Christian Franke

Ticket #876 has been marked as a duplicate of this ticket.

comment:5 Changed 18 months ago by Alex Samorukov

Attribute fixed, r4545. Still guessing, because there is no SMART info from the vendor.

comment:6 Changed 18 months ago by Alex Samorukov

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.