Opened 10 months ago

Closed 10 months ago

Last modified 10 months ago

#804 closed defect (fixed)

CSMI ports != 0 no longer accessible after an update of IRST driver to 15.2

Reported by: Zulkefli Aris Owned by: chrfranke
Priority: major Milestone: Release 6.6
Component: all Version: 6.5
Keywords: windows Cc: zulkefliaris@…

Description (last modified by chrfranke)

C:\>smartctl --scan
/dev/sda -d scsi # /dev/sda, SCSI device
/dev/csmi2,0 -d ata # /dev/csmi2,0, ATA device

C:\>smartctl -a  /dev/sda
smartctl 6.5 2016-05-07 r4318 [i686-w64-mingw32-win7(64)-sp1] (sf-6.5-1)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Vendor:               Intel
Product:              Raid 1 Volume
Revision:             1.0.
User Capacity:        500,105,547,264 bytes [500 GB]
Logical block size:   512 bytes
LU is fully provisioned
Rotation Rate:        5400 rpm
Logical Unit id:      0x785a2d5700000000001517ffff0aeb84
Serial number:        OutletSVR
Device type:          disk
Local Time is:        Wed Feb 08 09:05:58 2017 MPST
SMART support is:     Available - device has SMART capability.
SMART support is:     Enabled
Temperature Warning:  Disabled or Not Supported

=== START OF READ SMART DATA SECTION ===
SMART Health Status: OK
Current Drive Temperature:     0 C
Drive Trip Temperature:        0 C

Error Counter logging not supported

Device does not support Self Test logging


C:\>smartctl -a /dev/csmi2,0 -d ata
smartctl 6.5 2016-05-07 r4318 [i686-w64-mingw32-win7(64)-sp1] (sf-6.5-1)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Model Family:     Toshiba 2.5" HDD MQ01ABF...
Device Model:     TOSHIBA MQ01ABF050
Serial Number:    66R8P3FJT
LU WWN Device Id: 5 000039 71250ad18
Firmware Version: AM0P2A
User Capacity:    500,107,862,016 bytes [500 GB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    5400 rpm
Form Factor:      2.5 inches
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA8-ACS (minor revision not indicated)
SATA Version is:  SATA 3.0, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Wed Feb 08 09:07:19 2017 MPST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x00) Offline data collection activity
                                        was never started.
                                        Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0) The previous self-test routine completed
                                        without error or no self-test has ever
                                        been run.
Total time to complete Offline
data collection:                (  120) seconds.
Offline data collection
capabilities:                    (0x5b) SMART execute Offline immediate.
                                        Auto Offline data collection on/off support.
                                        Suspend Offline collection upon new
                                        command.
                                        Offline surface scan supported.
                                        Self-test supported.
                                        No Conveyance Self-test supported.
                                        Selective Self-test supported.
SMART capabilities:            (0x0003) Saves SMART data before entering
                                        power-saving mode.
                                        Supports SMART auto save timer.
Error logging capability:        (0x01) Error logging supported.
                                        General Purpose Logging supported.
Short self-test routine
recommended polling time:        (   2) minutes.
Extended self-test routine
recommended polling time:        ( 123) minutes.
SCT capabilities:              (0x003d) SCT Status supported.
                                        SCT Error Recovery Control supported.
                                        SCT Feature Control supported.
                                        SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000b   100   100   050    Pre-fail  Always       -       0
  2 Throughput_Performance  0x0005   100   100   050    Pre-fail  Offline      -       0
  3 Spin_Up_Time            0x0027   100   100   001    Pre-fail  Always       -       1394
  4 Start_Stop_Count        0x0032   100   100   000    Old_age   Always       -       17
  5 Reallocated_Sector_Ct   0x0033   100   100   050    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000b   100   100   050    Pre-fail  Always       -       0
  8 Seek_Time_Performance   0x0005   100   100   050    Pre-fail  Offline      -       0
  9 Power_On_Hours          0x0032   100   100   000    Old_age   Always       -       14
 10 Spin_Retry_Count        0x0033   100   100   030    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       16
191 G-Sense_Error_Rate      0x0032   100   100   000    Old_age   Always       -       0
192 Power-Off_Retract_Count 0x0032   100   100   000    Old_age   Always       -       4
193 Load_Cycle_Count        0x0032   100   100   000    Old_age   Always       -       164
194 Temperature_Celsius     0x0022   100   100   000    Old_age   Always       -       28 (Min/Max 21/33)
196 Reallocated_Event_Count 0x0032   100   100   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0032   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0030   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x0032   200   200   000    Old_age   Always       -       0
220 Disk_Shift              0x0002   100   100   000    Old_age   Always       -       0
222 Loaded_Hours            0x0032   100   100   000    Old_age   Always       -       13
223 Load_Retry_Count        0x0032   100   100   000    Old_age   Always       -       0
224 Load_Friction           0x0022   100   100   000    Old_age   Always       -       0
226 Load-in_Time            0x0026   100   100   000    Old_age   Always       -       250
240 Head_Flying_Hours       0x0001   100   100   001    Pre-fail  Offline      -       0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged.  [To run self-tests, use: smartctl -t]

SMART Selective self-test log data structure revision number 1
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.


C:\>smartctl -r ioctl,2 -d csmi --scan
 \\.\Scsi0:: successfully opened
  IOCTL_SCSI_MINIPORT(CC_CSMI_1) failed, Error=1
 \\.\Scsi1:: successfully opened
  IOCTL_SCSI_MINIPORT(CC_CSMI_1) failed, Error=1
 \\.\Scsi2:: successfully opened
  IOCTL_SCSI_MINIPORT(CC_CSMI_1) succeeded, bytes returned: 204
CSMI_SAS_DRIVER_INFO:
  Name:        "iaStorA"
  Description: "Intel(R) Rapid Storage Technology "
  Revision:    15.2
  IOCTL_SCSI_MINIPORT(CC_CSMI_20) succeeded, bytes returned: 2080
CSMI_SAS_PHY_INFO: NumberOfPhys=6
Phy[0] Port:   0x00
  Type:        0x10, 0x10
  InitProto:   0x01, 0x00
  TargetProto: 0x00, 0x01
  PhyIdent:    0x00, 0x00
  SASAddress:  00 00 00 00 00 00 00 00, 00 00 00 00 00 00 00 00
Phy[1] Port:   0x00
  Type:        0x10, 0x10
  InitProto:   0x01, 0x00
  TargetProto: 0x00, 0x01
  PhyIdent:    0x01, 0x01
  SASAddress:  00 00 00 00 00 00 00 00, 00 01 00 00 00 00 00 00
Phy[2] Port:   0x00
  Type:        0x10, 0x00
  InitProto:   0x01, 0x00
  TargetProto: 0x00, 0x01
  PhyIdent:    0x02, 0x02
  SASAddress:  00 00 00 00 00 00 00 00, 00 02 00 00 00 00 00 00
Phy[3] Port:   0x00
  Type:        0x10, 0x00
  InitProto:   0x01, 0x00
  TargetProto: 0x00, 0x01
  PhyIdent:    0x03, 0x03
  SASAddress:  00 00 00 00 00 00 00 00, 00 03 00 00 00 00 00 00
Phy[4] Port:   0x00
  Type:        0x10, 0x00
  InitProto:   0x01, 0x00
  TargetProto: 0x00, 0x01
  PhyIdent:    0x04, 0x04
  SASAddress:  00 00 00 00 00 00 00 00, 00 04 00 00 00 00 00 00
Phy[5] Port:   0x00
  Type:        0x10, 0x00
  InitProto:   0x01, 0x00
  TargetProto: 0x00, 0x01
  PhyIdent:    0x05, 0x05
  SASAddress:  00 00 00 00 00 00 00 00, 00 05 00 00 00 00 00 00
/dev/csmi2,0 -d ata # /dev/csmi2,0, ATA device

Change History (10)

comment:1 Changed 10 months ago by Zulkefli Aris

Cc: zulkefliaris@… added

comment:2 Changed 10 months ago by chrfranke

Description: modified (diff)

comment:3 Changed 10 months ago by chrfranke

Keywords: windows added
Milestone: Release 6.6
Owner: set to chrfranke
Status: newaccepted

The Type fields suggests that disks are connected to the first two ports and the other ports are empty. Correct?

smartctl 6.5 2016-05-07 r4318 [i686-w64-mingw32-win7(64)-sp1] (sf-6.5-1)

Please repeat the test with the 64-bit version of smartctl. I want to make sure that the problem is not related to the 32-bit part of the RST driver.

Looks like Intel again changed the CSMI port addressing. Result from RST 14.8.0.1042 on Windows 10:

  Revision:    14.8
...
Phy[0] Port:   0x00
...
  PhyIdent:    0x00, 0x00
...
Phy[1] Port:   0x01
...
  PhyIdent:    0x01, 0x00
...
Phy[2] Port:   0x02
...
  PhyIdent:    0x02, 0x00
ReleasebPortIdentifierAttached.bPhyIdentifier
14.8 Port number 0
15.2 0 Port number

The 15.2.0.1020 Release Notes suggest that there was actually some change in related CSMI code:

Ref NoDescriptionAffected OS's
1804279657 CSMI_SAS_PHY_INFO cannot be obtained on some kind of chipset windows_7_x64, windows_8.1_x64

comment:4 Changed 10 months ago by Zulkefli Aris

Milestone: Release 6.6

Correct. The disks are connected to the first two ports and the other ports are empty. Where can i get the 64bit version of smartctl? I only see the 32bit version at the download area.

Last edited 10 months ago by Zulkefli Aris (previous) (diff)

comment:5 Changed 10 months ago by chrfranke

Milestone: Release 6.6
Priority: minormajor

You already sent the output from 64-bit smartctl in the first version of the above comment, thanks :-)

Result is similar. Current smartmontools are no longer compatible with this version of the IRST driver.

Note that the smartmontools-VERSION.win32-setup.exe files contain both 32-bit (i686/x86) and 64-bit (x86_64) binaries (win32 is the name of the API). There is no need to actually install smartmontools. You could also unpack all files with 7-Zip.

PS:

  • Please do not paste smartctl output unchanged to tickets. Use plain-text attachments or wiki markup instead.
  • Please do not change or delete milestones.

comment:6 Changed 10 months ago by chrfranke

Summary: Smartctl version 6.5 not showing all intel raid disk when scan on Windows 7 64bitCSMI ports != 0 no longer accessible after an update of IRST driver to 15.2

Problem is not Win7 specific. It could be reproduced on Win10-1609 x64 after an update of IRST driver from 14.8.0.1042 to 15.2.0.1020.

comment:7 Changed 10 months ago by Zulkefli Aris

Milestone: Release 6.6
Priority: majorminor

Sorry for that.

comment:8 Changed 10 months ago by chrfranke

Milestone: Release 6.6
Priority: minormajor

Your above entry again changed settings (Milestone, Priority) back to default.

PLEASE USE "Preview" BEFORE "Submit changes".

comment:9 Changed 10 months ago by chrfranke

Resolution: fixed
Status: acceptedclosed

comment:10 Changed 10 months ago by chrfranke

If possible, please test most recent daily build.

Note: See TracTickets for help on using tickets.