Opened 7 years ago

Closed 5 months ago

#799 closed enhancement (fixed)

not in database SanDisk-SD8SNAT128G1002

Reported by: DELLIEUX Aurelien Owned by: Gabriele Pohl
Priority: minor Milestone: Release 7.5
Component: drivedb Version: 6.5
Keywords: ssd Cc: Peter Nowee

Description

SanDisk-SD8SNAT128G1002 is not in the database
the device is in an Asus ROG GL752VW

Attachments (4)

smartctl-SanDisk-SD8SNAT128G1002.txt (7.6 KB ) - added by DELLIEUX Aurelien 7 years ago.
HDD.jpg (500.0 KB ) - added by DELLIEUX Aurelien 7 years ago.
Sandisk Dashboard HDD infos
SMART.jpg (55.4 KB ) - added by DELLIEUX Aurelien 7 years ago.
Sandisk Dashboard SMART infos
smart.zip (24.1 KB ) - added by DELLIEUX Aurelien 5 years ago.

Download all attachments as: .zip

Change History (18)

by DELLIEUX Aurelien, 7 years ago

comment:1 by Christian Franke, 7 years ago

Component: alldrivedb
Milestone: Release 6.6

comment:3 by DELLIEUX Aurelien, 7 years ago

see ticket #712 ?

Version 0, edited 7 years ago by DELLIEUX Aurelien (next)

by DELLIEUX Aurelien, 7 years ago

Attachment: HDD.jpg added

Sandisk Dashboard HDD infos

by DELLIEUX Aurelien, 7 years ago

Attachment: SMART.jpg added

Sandisk Dashboard SMART infos

comment:4 by DELLIEUX Aurelien, 7 years ago

Sorry for the pictures, but Sandisk Dashboard does not provide data export...
i had to screen-capture each part and copy-paste to recombine the whole pictures...

comment:5 by Christian Franke, 7 years ago

Milestone: Release 6.6Release 6.7

comment:7 by DELLIEUX Aurelien, 6 years ago

Drive is present in an official Sandisk document :
https://www.sandisk.com/content/dam/sandisk-main/en_us/assets/resources/enterprise/data-sheets/z400s-mainstream.pdf

It is in the last Ordering Information table, line : M.2 2280 128GB SD8SNAT-128G

So it really seem to be a Z400S

[edit] confirmed with a google search :
https://www.google.fr/search?q=m2+sd8snat-128g&source=lnms&tbm=isch&sa=X&ved=0ahUKEwio5-eOtt3dAhUvyYUKHWWZCukQ_AUICygC&biw=1920&bih=938

Last edited 6 years ago by DELLIEUX Aurelien (previous) (diff)

comment:8 by Christian Franke, 5 years ago

Keywords: ssd added
Milestone: Release 6.7unscheduled

See also ticket #712.

by DELLIEUX Aurelien, 5 years ago

Attachment: smart.zip added

comment:9 by DELLIEUX Aurelien, 5 years ago

i found some interesting informations in the installation directory of Sandisk SSD Dashboard 2.3.3.0
the "smart" dir seems to contain smart data for numerous models.
fox example i retrieved my personal ssd which is a SanDisk SDSSDA240G (not the one of this ticket), firmware version Z32080RL.
reading smart_list.xml, and because firmware starts with z3, i can next read nike_generic.xml file
please look at the smart.zip attachment

Following the smart_list.xml, we can now tell the ssd device for this ticket is an aphrodite2_generic, with the following details :

<?xml version="1.0" encoding="UTF-8"?>
<!-- Please change version number below & update the version in
the smart_list.xml whenever changes are made to the XML -->
<smart version="1.3">

<aname id="5">Reassigned Block Count</aname>
<aname id="9">Power On Hours</aname>
<aname id="12">Drive Power Cycle Count</aname>
<aname id="166">Minimum P/E Cycles</aname>
<aname id="167">Maximum Bad Blocks per die</aname>
<aname id="168">Maximum P/E Cycles</aname>
<aname id="169">Total Bad Blocks</aname>
<aname id="170">Grown Bad Blocks</aname>
<aname id="171">Program Fail Count</aname>
<aname id="172">Erase Fail Count</aname>
<aname id="173">Average P/E Cycles</aname>
<aname id="174">Unexpected Power Loss Count</aname>
<aname id="187">UECC Count</aname>
<aname id="194" raw="2:0" format="XF">Enclosure Temperature</aname>
<aname id="199">SATA CRC Errors</aname>
<aname id="230" raw="1:0" format="XH.XL %">Media Wearout Indicator</aname>
<aname id="232" better="1" field="0" format="XL %">Available Reserve Space</aname>
<aname id="233">NAND GB Written</aname>
<aname id="241">Total GB Write</aname>
<aname id="242">Total GB Read</aname>
<aname id="244" field="0" format="BINARY">Temperature Throttle Status</aname>

</smart>

hope this helps a little...

comment:10 by Christian Franke, 5 years ago

Thanks for the info.

See also ticket #464.

comment:11 by Peter Nowee, 5 years ago

Cc: Peter Nowee added

comment:12 by Peter Nowee, 5 years ago

I just created ticket #1232 for model SanDisk SD8SBAT128G1002.

My model is also marketed as Z400s and is also shown in the SanDisk PDF linked to in comment:7. The only difference seems to be the form factor (M.2 2280 for SD8SBAT, 2.5”/7mm cased for SD8SNAT). The PDF also lists other form factors and sizes, 13 models in total.

My drive also suffers from the same problems as the OP mentioned on the old smartmontools-support mailing list in 2017 (invalid SMART checksum, ATA error count 65535 inconsistent with error log pointer): https://sourceforge.net/p/smartmontools/mailman/message/35636112/ . Not to hijack this ticket for that issue, but it just shows that the drives are internally probably very much the same.

comment:13 by Gabriele Pohl, 5 months ago

Owner: set to Gabriele Pohl
Status: newaccepted

added in r5561

comment:14 by Christian Franke, 5 months ago

Milestone: unscheduledRelease 7.5
Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.