Opened 3 years ago

Closed 22 months ago

Last modified 7 months ago

#767 closed enhancement (fixed)

Please add WD Blue PC SSD to the DB

Reported by: Attila Fazekas Owned by:
Priority: minor Milestone: Release 6.6
Component: drivedb Version: 6.5
Keywords: Cc:

Description (last modified by Christian Franke)

The related smart data was published in the WDSSDDashboardSetup.zip downloadable from
https://support.wdc.com/downloads.aspx?p=279 .

.rsrc/BIN/41 .rsrc/BIN/42 xml files contains the SSD related attribute names and IDs.

I added the following entry to my drivedb.h .

  { "WD Blue PC SSD",
    "WDC WDS...[TG]1B0[AB].*",
    "", "", // all extra attribute is raw48 until otherwise proven
    "-v 165,raw48,Block_Erase_Count "
    "-v 166,raw48,Minimum_PE_Cycles "
    "-v 167,raw48,Max_Bad_Blocks_per_Die "
    "-v 168,raw48,Maximum_PE_Cycles "
    "-v 169,raw48,Total_Bad_Blocks "
    "-v 170,raw48,Grown_Bad_Blocks "
    "-v 171,raw48,Program_Fail_Count "
    "-v 172,raw48,Erase_Fail_Count "
    "-v 173,raw48,Average_PE_Cycles "
    "-v 174,raw48,Unexpected_Power_Loss "
    "-v 230,raw48,Media_Wearout_Indicator "
    "-v 234,raw48,NAND_GB_Written_SLC "  //233 NAND GB Written TLC
    "-v 241,raw48,Total_GB_Written "
    "-v 242,raw48,Total_GB_Read "
    "-v 244,raw48,Temp_Throttle_Status "
  },

It seams to be working on my:

=== START OF INFORMATION SECTION ===
Model Family:     WD Blue PC SSD
Device Model:     WDC WDS100T1B0A-00H9H0
Serial Number:    163966421753
LU WWN Device Id: 5 001b44 4a64c7f6f
Firmware Version: X41000WD
User Capacity:    1,000,204,886,016 bytes [1.00 TB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    Solid State Device
Form Factor:      2.5 inches
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ACS-2 T13/2015-D revision 3
SATA Version is:  SATA 3.2, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Thu Nov 17 07:26:20 2016 CET
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

I narrowed the regexp to the https://www.wdc.com/products/solid-state-drives/wd-blue-ssd.html , but IMHO it could be added to all "WDC WDS.*" at the moment.

Attachments (5)

wd_blue.patch (1.2 KB) - added by Attila Fazekas 3 years ago.
smc-x-after-patch.txt (6.4 KB) - added by Attila Fazekas 3 years ago.
smartctl -x /dev/sdf [after the db change]
smc-x-before-patch.txt (6.4 KB) - added by Attila Fazekas 3 years ago.
WD_Blue_PC_SSD_smartctl_x_6.5.txt
smartmontools_wds_blue_pc_ssd.2.patch (1.6 KB) - added by Attila Fazekas 3 years ago.
smartmontools_wds_blue_pc_ssd.patch (1.6 KB) - added by Attila Fazekas 3 years ago.
smartmontools_wds_blue_pc_ssd.patch

Download all attachments as: .zip

Change History (15)

Changed 3 years ago by Attila Fazekas

Attachment: wd_blue.patch added

comment:1 Changed 3 years ago by Attila Fazekas

Type: defectenhancement

comment:2 Changed 3 years ago by Christian Franke

Description: modified (diff)

comment:3 Changed 3 years ago by Christian Franke

Component: alldrivedb
Milestone: Release 6.6
Priority: majorminor

Thanks.

Please provide a full smartctl -x output of this device as an attachment.

Changed 3 years ago by Attila Fazekas

Attachment: smc-x-after-patch.txt added

smartctl -x /dev/sdf [after the db change]

Changed 3 years ago by Attila Fazekas

Attachment: smc-x-before-patch.txt added

WD_Blue_PC_SSD_smartctl_x_6.5.txt

comment:4 Changed 3 years ago by Christian Franke

230 Media_Wearout_Indicator -O--CK   100   100   ---    -    47244640267
...
233 Media_Wearout_Indicator -O--CK   100   100   ---    -    835

It is possibly better to use raw16 (11, 0, 11) or hex48 (0x000b0000000b) format for attribute 230.

Attributes 230 and 233 have same name but different raw values.

comment:5 Changed 3 years ago by Attila Fazekas

The xml from WD names the 233 differently!

"233" is "NAND GB Written TLC"
"234" is "NAND GB Written SLC"

Both value is close to the
241 Total_GB_Written or Host_Total_GB_Written.

comment:6 Changed 3 years ago by Attila Fazekas

"It utilizes a SLC cache technology" (I just read in article, the spam protector prevents me to link it)

It explains why I have both TLC and SLC attribute on the same device.

The content of the 2 xml:
https://paste.fedoraproject.org/483672/47937596/

comment:7 Changed 3 years ago by Attila Fazekas

In the new patch I tried to match the db file style, and added some commented attribute.

I changed the 230 to hex48, the value does not changed today, it does not seams to be something frequently changing/counting.

Added the TLC suffix where it made sense.
Total_GB_Written replaced to 'Total_Host_GB_Written' to be more similar to the vendor's xml name.

Changed 3 years ago by Attila Fazekas

Changed 3 years ago by Attila Fazekas

smartmontools_wds_blue_pc_ssd.patch

comment:8 Changed 22 months ago by Alex Samorukov

Resolution: fixed
Status: newclosed

Than you, done in the r4469.

comment:9 Changed 22 months ago by Christian Franke

Merged in r4490.

comment:10 Changed 7 months ago by Christian Franke

Ticket #771 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.