Opened 3 years ago

Closed 3 years ago

#727 closed defect (invalid)

smartctl hangs with Areca 1883

Reported by: Iavor Stoev Owned by:
Priority: major Milestone:
Component: smartctl Version: 6.4
Keywords: Cc:

Description

Hello,

We have hundreds of Areca RAID controllers model ARC1231/ARC1882 in production,
and we use smartctl to poll the SMART parameters of the drives for our monitoring needs.

Several months ago we have started using Areca 1883 controllers in our latest servers.

The new machines are with the following hardware & software setup:

SuperMicro? X10DRI-T BIOS v2.0

SuperMicro? CA-846BA9B chassis

2 x ARC-1883IX-24
Firmware Version : V1.52 2015-11-20

Each of the Areca controllers has 12 x INTEL P3500 1.2TB SSD drives.

Areca CLI, Version: 1.14.7, Arclib: 350, Date: May 19 2015( Linux )

Debian Jessie Stable with kernel 3.16.17 + latest driver from dkms
arcmsr version v1.30.0X.23-20151225

The controllers work fine but we experience the following issue:
After several hours of uptime, the smartctl utility that we invoke every 5 minutes stalls and it's unable to display any information.
The same is true if we try to use areca CLI utility.

When the problem occurs, the strace of the smartctl/CLI process, shows that the it is waiting for sg3 or sg1:
open("/dev/sg3" (device or resource busy)

sg_map shows the following info

/dev/sg0 /dev/sda - Areca 1883
/dev/sg1
/dev/sg2 /dev/sdb - Areca 1883
/dev/sg3

If we execute sg_reset for the problem sg device, it sometime solves the problem, but sometime leaves the machine with a bad I/O performance and we needd to
reboot the machine in order to restore the performance.

If we stop using smartctl and switch to areca CLI in order to collect the SMART parameters
(the problem is that the CLI displays very limited amount of SMART parameters) everything works fine.

We experience the issue with all of the following smartmontools versions: 6.3+svn4002-2+b2 6.4+svn4214-1 6.5+svn4324.

Could you advise what could be done in order to solve this issue?
If you need any other information or debug info we will be glad to provide it.

We haven't experienced such issue with any of our servers with Areca 1231 & 1882 controllers and the same hardware & software setup.

Thank you

Iavor Stoev
Project Manager Head of System & Network Administration Department
ICDSoft Ltd - http://icdsoft.com

Change History (2)

comment:1 in reply to:  description Changed 3 years ago by Christian Franke

Milestone: undecided

After several hours of uptime, the smartctl utility that we invoke every 5 minutes stalls and it's unable to display any information.
...
If we stop using smartctl and switch to areca CLI in order to collect the SMART parameters ... everything works fine.

Please be more specific as the problem might be related to driver/firmware functionality used by smartctl but not by areca CLI.

Which smartctl command lines are invoked every 5 minutes ?

Please provide a sample smartctl debug output (add option -r ioctl,2) for one P3500 drive as an attachment to this ticket.

comment:2 Changed 3 years ago by Christian Franke

Milestone: undecided
Resolution: invalid
Status: newclosed

No feedback.

Note: See TracTickets for help on using tickets.