Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#683 closed patch (fixed)

[PATCH] Drive "USB: Buffalo MiniStation Safe HD-PNFU3" 0x0411:0x0251

Reported by: sping Owned by: Christian Franke
Priority: minor Milestone: Release 6.5
Component: drivedb Version: 6.4
Keywords: Cc:

Description

Patch and smartctl -x output attached, enjoy :)

Attachments (3)

smartctl-BUFFALO-MINISTATION_SAFE_HD_PNFU3.patch (390 bytes) - added by sping 3 years ago.
Patch against trunk drivedb.h
smartctl-BUFFALO-MINISTATION_SAFE_HD_PNFU3.txt (11.5 KB) - added by sping 3 years ago.
Output of smartctl -x …
smartctl-BUFFALO-MINISTATION_SAFE_HD_PNFU3-ioctl-2.txt (13.9 KB) - added by sping 3 years ago.
Output related to ioctl 2

Download all attachments as: .zip

Change History (11)

Changed 3 years ago by sping

Patch against trunk drivedb.h

Changed 3 years ago by sping

Output of smartctl -x ...

comment:1 Changed 3 years ago by Christian Franke

Keywords: usb buffalo removed
Priority: majorminor

comment:2 Changed 3 years ago by Christian Franke

Owner: set to Christian Franke
Status: newaccepted

comment:3 Changed 3 years ago by Christian Franke

Resolution: fixed
Status: acceptedclosed

comment:4 Changed 3 years ago by Christian Franke

Unrelated to drivedb entry:

SMART Status command failed
Please get assistance from http://smartmontools.sourceforge.net/
Register values returned from SMART Status command are:
ERR=0x00, SC=0x00, LL=0x00, LM=0x00, LH=0x00, DEV=0x00, STS=0x00
SMART Status not supported: Invalid ATA output register values

Looks like this bridge returns a correct ATA Return Descriptor but sets all output register values to 0.

Please provide output of smartctl -r ioctl,2 -q noserial -H ....

Changed 3 years ago by sping

Output related to ioctl 2

comment:5 Changed 3 years ago by sping

Thanks for adding to the database.

Please find the requested command output attached. Best, S

comment:6 Changed 3 years ago by Christian Franke

Thanks for debug output. This bridge returns same incomplete sense data as described in ticket #612. Smartctl >= r4130 should print Incomplete response, ATA output registers missing.

comment:7 Changed 3 years ago by sping

I can confirm that r4312 does, tested just now.

comment:8 Changed 3 years ago by Christian Franke

Thanks!

Note: See TracTickets for help on using tickets.