Opened 4 years ago

Closed 4 years ago

#594 closed enhancement (fixed)

add supported device Mediasonic PROBOX K32-SU3 USB3 3.5" enclosure

Reported by: Steve Newcomb Owned by: Christian Franke
Priority: minor Milestone: Release 6.5
Component: drivedb Version: 6.4
Keywords: Cc:

Description

MediaSonic? PROBOX K32-SU3 3.5-inch USB 3.0 (mediasonic.ca)
smartctl reports: "Unknown USB bridge [0x2109:0x0711 (0x114)]"

Change History (9)

comment:1 Changed 4 years ago by Christian Franke

Component: wikidrivedb
Keywords: unsupported device unknown bridge removed
Milestone: undecided
Priority: majorminor
Type: defectenhancement

"Unknown USB bridge" means that the USB ID is not in the drive database. This does not imply that that device is not supported.

The USB ID suggest that this device uses a VIA VL711 USB to SATA bridge. The older VL701 reportedly supports SAT, see drivedb.h.

Please try whether smartctl -d sat -x ... works and report the result here.

comment:2 Changed 4 years ago by Steve Newcomb

root@guy:~# smartctl -d sat -x /dev/sdf
smartctl 6.2 2013-07-26 r3841 [x86_64-linux-3.16.0-43-generic] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

Read Device Identity failed: scsi error unsupported field in scsi command

A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.

comment:3 Changed 4 years ago by Christian Franke

Milestone: undecidedRelease 6.5

If -d sat,12 does also not work, VIA has apparently removed SAT support in the firmware of newer bridges.

comment:4 Changed 4 years ago by Steve Newcomb

-d sat,12

gives the same result as

-d sat

comment:5 Changed 4 years ago by Christian Franke

Owner: set to Christian Franke
Status: newaccepted

comment:6 Changed 4 years ago by Christian Franke

Resolution: fixed
Status: acceptedclosed

comment:7 Changed 4 years ago by smartuser

Resolution: fixed
Status: closedreopened

Please modify the DB changes with regard this VIA chipset to "partly supported" (at least under GNU/Linux).

The chipset actually works with a simple -d option:

sudo /usr/sbin/smartctl -d sat -x /dev/sdb

The problem is when the enclosure runs in the enhanced UASP mode. Disabling UASP for the enclosure should allow access to the SMART functions of the the underlying drive.

The trick is to blacklist the UAS driver and force the kernel to use the default USB mass storage driver. This can be done by creating a module options file inside /etc/modprobe.d/.

For example in my case, the file is named:

/etc/modprobe.d/ignore-uas.conf

The important thing is the extension (.conf). The contents of the file is the following line:

options usb-storage quirks=2109:0711:u

The alphanumeric code after quirks= is the USB vendor and product IDs output by dmesg or lusub.

The additional module directive should work without rebooting provided the "uas" module is not loaded. If the module has already been loaded, you can try to unload it using the command "modprobe -r uas" before inserting or reinserting your USB enclosure.

Example dmesg output after the blacklisting:

[73159.979251] usb 2-2: new SuperSpeed USB device number 4 using xhci_hcd
[73160.000423] usb 2-2: New USB device found, idVendor=2109, idProduct=0711
[73160.000436] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[73160.000445] usb 2-2: Product: USB3.0 SATA Bridge
[73160.000451] usb 2-2: Manufacturer: VIA Labs,Inc.
[73160.000458] usb 2-2: SerialNumber: 000000000024
[73160.068784] usb 2-2: UAS is blacklisted for this device, using usb-storage instead
[73160.068801] usb-storage 2-2:1.0: USB Mass Storage device detected
[73160.069626] usb-storage 2-2:1.0: Quirks match for vid 2109 pid 0711: 800000
[73160.069891] scsi host3: usb-storage 2-2:1.0
[73160.070604] usbcore: registered new interface driver usb-storage
[73160.077129] usbcore: registered new interface driver uas
[73162.669280] scsi 3:0:0:0: Direct-Access     WDC WD10 JPVX-16JC3T0     01.0 PQ: 0 ANSI: 6
[73162.672202] sd 3:0:0:0: [sdb] 1953525164 512-byte logical blocks: (1.00 TB/931 GiB)

Incidentally, smartctl for this chipset works out-of-the-box in Ubuntu 14.04, probably because its 3.x kernel still doesn't include uas support, but not in the latest Debian unstable (Linux 4.x).

Last edited 4 years ago by smartuser (previous) (diff)

comment:8 Changed 4 years ago by Christian Franke

Status: reopenedaccepted

comment:9 Changed 4 years ago by Christian Franke

Resolution: fixed
Status: acceptedclosed
Summary: add unsupported device Mediasonic PROBOX K32-SU3 USB3 3.5" enclosureadd supported device Mediasonic PROBOX K32-SU3 USB3 3.5" enclosure
Note: See TracTickets for help on using tickets.