Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#551 closed enhancement (fixed)

Seagate Vendor Specific Smart Attribute 188

Reported by: Tony Oreglia Owned by: Christian Franke
Priority: minor Milestone: Release 6.5
Component: drivedb Version: 6.3
Keywords: Cc: michael.tippie@…

Description

The raw data for attribute 188 is divided into three words from the seven raw bytes available.
Each word defines a timeout and timing associated with the command timeout.

[0:1] Command Timeout Occurred
[2:3] Command Timeout Occurred, command was in queue >5 seconds
[4:5] Command Timeout Occurred, command was in queue >7.5 seconds

so the output 03 00 03 00 03 suggests that there are three timeouts, three 5 second timeouts, and three 7 second timeouts. Note that a 7 second timeout also counts as a five second. But a 5 second timeout doesn't count as a 7 second timeout. So this number really means that there were 3 7 second timeouts.

So the issue is that smartctl is reading that entire block as a single very large number. So I'm going to see if their is a more up to date version of smartctl, to see if this fixes the issue -- if not I'll open a bug report to smartctl so they know to fix it.

Change History (4)

comment:1 Changed 4 years ago by Christian Franke

Component: smartctldrivedb
Keywords: SMART attribute 188 Timeout TO removed
Milestone: undecided
Priority: majorminor
Type: defectenhancement

The info "Seagate" is far too generic as there are many Seagate HDD series in drivedb.h, including very old (10+ years) ones:

$ svnversion drivedb.h
4092

$ grep '^  { "Seagate' drivedb.h |
  egrep -v 'Maxtor|Samsung|SpinPoint|CompactFlash' | wc -l
92

If possible, please provide:

  • a list of affected Seagate drive series
  • links to SMART specs for these series
  • sample smartctl -x output (as plain text attachments) for affected drives you have access to.

Note that option -v 188,raw16 is already set in seven Seagate drivedb entries.

comment:2 Changed 4 years ago by Christian Franke

Milestone: undecidedRelease 6.5
Owner: set to Christian Franke
Status: newaccepted

Affected drive:

Device Model:     ST6000NM0024-1HT17Z
...
188 Command_Timeout         -O--CK   100   100   000    -    12885098499

12885098499 = 0x000300030003

A drivedb.h entry already exists but it lacks the -v 188,raw16 option.

comment:3 Changed 4 years ago by Alex Samorukov

Resolution: fixed
Status: acceptedclosed

attribute added in r4128

comment:4 Changed 4 years ago by Christian Franke

Merged to branches in r4133.

Note: See TracTickets for help on using tickets.