Opened 5 years ago

Closed 5 years ago

#435 closed defect (fixed)

Windows 7 Full Install - Error in PATH variable

Reported by: Josh Owned by: Christian Franke
Priority: major Milestone: Release 6.4
Component: all Version: 6.3
Keywords: windows, installer Cc:

Description

When installing via the "Full" option on Windows 7, the PATH variable is not being set correctly. It must be added with quotes around it. Spaces will cause the entire variable to be ignored.

Incorrect: C:\Program Files\smartmontools\bin
Correct: "C:\Program Files\smartmontools\bin"

Change History (7)

comment:1 Changed 5 years ago by Alex Samorukov

Keywords: installer added; install path variable 7 removed

comment:2 Changed 5 years ago by Christian Franke

Could not reproduce.

The installer changes the (user specific part of the) PATH variable by changing the registry value HKEY_CURRENT_USER\Environment\PATH. No quotes are needed then.

Please check whether this registry value is longer than 1023. Then PATH manipulation fails due to a string length limitation of the NSIS installer. This is actually an open issue.

comment:3 Changed 5 years ago by Josh

PATH was empty except for the value added. The value type is REG_SZ not REG_EXPAND_SZ if that makes a difference. I will try installs on more machines and see if I can reproduce.

comment:4 Changed 5 years ago by Christian Franke

Milestone: Release 6.4
Owner: set to Christian Franke
Priority: minormajor
Status: newaccepted

This is the unfortunate result of a bug in the NSIS function ReadRegStr. If the registry value is longer than 1023, it returns an empty string instead of failure.

As a workaround, uncheck "Add install dir to PATH" if the user part of the PATH is very long.

comment:5 Changed 5 years ago by Josh

My particular issue was not due to string length. This was the only value in the user Path variable. Unfortunately I cannot seem to reproduce it now. I thought it might have to do with registry value type but doesn't seem to be the case. It refused to work and had to add quotes. Now it works fine without even if I uninstall and re-install. Sorry for the wasted ticket.

comment:6 Changed 5 years ago by Christian Franke

I keep the ticket open. The string length issue should be fixed.

comment:7 Changed 5 years ago by Christian Franke

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.