Opened 10 years ago

Closed 8 years ago

#38 closed defect (fixed)

SMART errors upon resuming from suspend

Reported by: Giuseppe Iuculano Owned by: Christian Franke
Priority: minor Milestone: Release 5.42
Component: smartd Version: 5.39
Keywords: Cc: 563256-forwarded@…

Description

Hi,

I'm forwarding a bug reported by a Debian user.
Version: smartctl 5.39 2009-12-09 r2995 [i686-pc-linux-gnu] (local build)

upon resuming from suspend to ram (iirc, it does not affect suspend to disk, but i would not bet now), smartd logs+mails various messages:

info smartd[1625]: Device: /dev/hda, not capable of SMART self-check
crit smartd[1625]: Device: /dev/hda, failed to read SMART Attribute Data
info smartd[1625]: Device: /dev/hda, Read SMART Self Test Log Failed
info smartd[1625]: Device: /dev/hda, Read SMART Error Log Failed

after /etc/init.d/smartmontools restart, everything seems just fine.

Change History (6)

comment:1 Changed 9 years ago by Christian Franke

Keywords: linux added

comment:2 Changed 8 years ago by Alex Samorukov

Resolution: worksforme
Status: newclosed

I am not able to reproduce this bug, report was > 1 year ago and reason is probably related to kernel power management and has nothing to do with smartd.

comment:3 Changed 8 years ago by Christian Franke

Resolution: worksforme
Status: closedreopened

comment:4 Changed 8 years ago by Christian Franke

Keywords: linux removed
Milestone: Release 5.42

Could reproduce similar problem on Windows with Intel chipset and driver. Some pass-through I/O-controls apparently fail if called immediately after resume from suspend.

Adding extra sleep() time after resume from suspend fixes this.

comment:5 Changed 8 years ago by Christian Franke

Owner: changed from somebody to Christian Franke
Status: reopenedassigned

comment:6 Changed 8 years ago by Christian Franke

Resolution: fixed
Status: assignedclosed

r3424, already included in 5.42.

Note: See TracTickets for help on using tickets.