Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#347 closed defect (invalid)

invalid SMART checksum bug

Reported by: anemmer Owned by:
Priority: minor Milestone:
Component: smartctl Version: 5.39.1
Keywords: Cc:

Description

I am getting an "invalid SMART checksum" error when I run smartctl and there is not documentation for it and I can't find anything on the web about it so I think it may be a bug. Please investigate. Thank you.

Change History (4)

comment:1 Changed 5 years ago by Alex Samorukov

  1. Message itself indicates that SMART data coming from drive has uncorrect chipset. This could be caused by different reasons, including firmware/drive issues, OS or controller bug.
  2. If you want some help please provide more details about your OS and hardware.
  3. Before reporting please update to the recent smartmontools version and if bug is reproducible - send smartctl full output to this ticket.

comment:2 Changed 5 years ago by Christian Franke

Keywords: invalid smart checksum bug removed

The "invalid SMART checksum" warning is often reported for still empty SMART error or self-test logs. This is harmless and could be ignored.

Please provide a sample output as attachment(!) to this ticket.

comment:3 Changed 5 years ago by anemmer

smartctl 5.39.1 2010-01-28 r3054 [i486-slackware-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net
=== START OF INFORMATION SECTION ===
Model Family:     Hitachi Deskstar 7K80 series
Device Model:     HDS728080PLAT20
Serial Number:    PFD219SYU97E1E
Firmware Version: PF2OA2AA
User Capacity:    82,348,277,760 bytes
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   7
ATA Standard is:  ATA/ATAPI-7 T13 1532D revision 1
Local Time is:    Tue Aug 19 11:56:41 2014 MST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x00)	Offline data collection activity
					was never started.
					Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0)	The previous self-test routine completed
					without error or no self-test has ever 
					been run.
Total time to complete Offline 
data collection: 		 (1828) seconds.
Offline data collection
capabilities: 			 (0x5b) SMART execute Offline immediate.
					Auto Offline data collection on/off support.
					Suspend Offline collection upon new
					command.
					Offline surface scan supported.
					Self-test supported.
					No Conveyance Self-test supported.
					Selective Self-test supported.
SMART capabilities:            (0x0003)	Saves SMART data before entering
					power-saving mode.
					Supports SMART auto save timer.
Error logging capability:        (0x01)	Error logging supported.
					General Purpose Logging supported.
Short self-test routine 
recommended polling time: 	 (   1) minutes.
Extended self-test routine
recommended polling time: 	 (  31) minutes.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000b   100   100   016    Pre-fail  Always       -       0
  2 Throughput_Performance  0x0005   100   100   050    Pre-fail  Offline      -       0
  3 Spin_Up_Time            0x0007   106   106   024    Pre-fail  Always       -       197 (Average 180)
  4 Start_Stop_Count        0x0012   100   100   000    Old_age   Always       -       175
  5 Reallocated_Sector_Ct   0x0033   100   100   005    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000b   100   100   067    Pre-fail  Always       -       0
  8 Seek_Time_Performance   0x0005   100   100   020    Pre-fail  Offline      -       0
  9 Power_On_Hours          0x0012   095   095   000    Old_age   Always       -       35999
 10 Spin_Retry_Count        0x0013   100   100   060    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       175
192 Power-Off_Retract_Count 0x0032   099   099   050    Old_age   Always       -       1667
193 Load_Cycle_Count        0x0012   099   099   050    Old_age   Always       -       1667
194 Temperature_Celsius     0x0002   144   144   000    Old_age   Always       -       38 (Lifetime Min/Max 17/46)
196 Reallocated_Event_Count 0x0032   100   100   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0022   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0008   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x000a   200   200   000    Old_age   Always       -       0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Short offline       Completed without error       00%     35914         -
# 2  Short offline       Completed without error       00%     35913         -

Warning! SMART Selective Self-Test Log Structure error: invalid SMART checksum.
SMART Selective self-test log data structure revision number 1
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.
Last edited 5 years ago by Alex Samorukov (previous) (diff)

comment:4 Changed 5 years ago by Christian Franke

Resolution: invalid
Status: newclosed

This is a harmless drive firmware bug which could be safely ignored. It is not a smartctl bug.

The warning may possibly disappear when the Selective Self-Test log is no longer empty. The warning could also be suppressed with the -b ignore option, see man page.

Please note that your smartctl version 5.39.1 is very old. The 5.39 drive database branch is no longer updated since 2011.

BTW: For future problem reports PLEASE don't paste smartctl sample output to a ticket comment. Use an attachment or alternatively Wiki Formatting syntax for Preformatted Text, thanks.

Note: See TracTickets for help on using tickets.