Opened 6 years ago

Closed 2 years ago

Last modified 13 months ago

#313 closed enhancement (fixed)

/dev/disk/by-id in smartd.conf ignored

Reported by: bond711 Owned by: Christian Franke
Priority: major Milestone: Release 6.6
Component: smartd Version: 6.2
Keywords: smartd.conf Cc: Nathan Stratton Treadway

Description

~$ cat /etc/smartd.conf
/dev/disk/by-id/scsi-SATA_KingSpec_KDM-44VVS14413121600085 -I 194
#/dev/sdb -I 194
DEVICESCAN -a -o on -S on -n standby,q -s (S/../.././02|L/../../6/03) -W 4,40,45 -m root

referencing the disk directly allows my to exclude it from temperature monitoring, using /by-id/ fails

~$ journalctl -f

Jan 29 14:28:17 store04 smartd[1337]: smartd 6.2 2013-07-26 r3841 [i686-linux-3.11.6-4-pae] (SUSE RPM)
Jan 29 14:28:17 store04 smartd[1337]: Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org
Jan 29 14:28:17 store04 smartd[1337]: Opened configuration file /etc/smartd.conf
Jan 29 14:28:17 store04 smartd[1337]: Drive: /dev/disk/by-id/scsi-SATA_KingSpec_KDM-44VVS14413121600085, implied '-a' Directive o...rtd.conf
Jan 29 14:28:17 store04 smartd[1337]: Configuration file /etc/smartd.conf was parsed, found DEVICESCAN, scanning devices
Jan 29 14:28:17 store04 smartd[1337]: Device: /dev/disk/by-id/scsi-SATA_KingSpec_KDM-44VVS14413121600085, type changed from 'scsi' to 'sat'
Jan 29 14:28:17 store04 smartd[1337]: Device: /dev/disk/by-id/scsi-SATA_KingSpec_KDM-44VVS14413121600085 [SAT], opened
...
Jan 29 14:28:17 store04 smartd[1337]: Device: /dev/sdb [SAT], opened
Jan 29 14:28:17 store04 smartd[1337]: Device: /dev/sdb [SAT], KingSpec KDM-44VS.1-008GSS, S/N:VS14413121600085, FW:20131018, 7.91 GB
...
Jan 29 14:28:19 store04 smartd[1337]: Device: /dev/sdb [SAT], Temperature 54 Celsius reached critical limit of 45 Celsius (Min/Max 54/60)

Change History (6)

comment:1 Changed 6 years ago by Christian Franke

Component: allsmartd
Keywords: smartd.conf added
Owner: changed from somebody to Christian Franke
Status: newaccepted
Type: defectenhancement

The current duplicate device detection only checks path names. It should also check device identify information.

comment:2 Changed 5 years ago by Christian Franke

Milestone: unscheduled

comment:3 Changed 2 years ago by Christian Franke

Milestone: unscheduledRelease 6.6

comment:4 Changed 2 years ago by Christian Franke

Resolution: fixed
Status: acceptedclosed

comment:5 Changed 20 months ago by Christian Franke

Ticket #1015 has been marked as a duplicate of this ticket.

comment:6 Changed 13 months ago by Nathan Stratton Treadway

Cc: Nathan Stratton Treadway added
Note: See TracTickets for help on using tickets.