Opened 6 years ago

Closed 5 years ago

#305 closed defect (wontfix)

smartctl loses 1 byte from response to scsiModeSense in FreeBSD

Reported by: fedsim Owned by: Alex Samorukov
Priority: major Milestone:
Component: all Version: 6.2
Keywords: freebsd Cc:

Description

smartctl -a (and smartd as well) gives an error when trying to examine some disks because the response to a mode sense command cannot be parsed (see attached file smartctl.log).

However, if the same command is sent with camcontrol, the response is correct (note the leading byte in camcontrol.log, which is not present in smartctl.log).

Attachments (3)

smartctl.log (4.1 KB) - added by fedsim 6 years ago.
Log of smartctl -a
camcontrol.log (304 bytes) - added by fedsim 6 years ago.
Log of camcontrol
smartctl-r3874.log (3.2 KB) - added by fedsim 5 years ago.

Download all attachments as: .zip

Change History (17)

Changed 6 years ago by fedsim

Attachment: smartctl.log added

Log of smartctl -a

Changed 6 years ago by fedsim

Attachment: camcontrol.log added

Log of camcontrol

comment:1 Changed 6 years ago by Christian Franke

Milestone: Release 6.3

comment:2 Changed 6 years ago by Christian Franke

Keywords: freebsd added

comment:3 Changed 5 years ago by Christian Franke

This was possibly fixed with r3873. Please test current SVN version of smartctl.

Changed 5 years ago by fedsim

Attachment: smartctl-r3874.log added

comment:4 Changed 5 years ago by fedsim

Nope. The missing byte is still... missing (see smartctl-r3874.log)

comment:5 Changed 5 years ago by Alex Samorukov

We dont have any similar reports. Are you sure that your kernel is in sync with your includes and source tree?

comment:6 Changed 5 years ago by fedsim

I've had this issue not only when compiling from source but with precompiled smartmontools in FreeNAS 8.3...9.2.1 too. I wouldn't think that is the case but I'd appreciate some help on how to check this because I'm no expert at all when it comes to FreeBSD.

Anyway, this seems to happen only with the SAS disks in the machine. SATA disks work just fine, as do those same SAS disks when I plug them in a Linux box. Hope this helps.

comment:7 Changed 5 years ago by Alex Samorukov

Owner: changed from somebody to Alex Samorukov
Status: newaccepted

Thank you for feedback, it seems to be a bug then. Is it possible to provide somehow access to the affected machine? I really have no idea whats going on and unfortunately unable to reproduce this locally.

comment:8 Changed 5 years ago by fedsim

The machine is in production right now. I can give you unprivileged access and do the real testing for you. Would that help?

comment:9 Changed 5 years ago by Alex Samorukov

This should help a little, at least. I`ll compile version which will print a lot of debug to show why answer from smartctl is so different compared to camcontrol tool. my email is samm@…

comment:10 Changed 5 years ago by Christian Franke

Milestone: Release 6.3Release 6.4

comment:11 Changed 5 years ago by Alex Samorukov

Resolution: fixed
Status: acceptedclosed

Hi, unfortunately i am unable to work on this ticket w/o root access. If you have possibility to provide it i will continue working on it.

comment:12 Changed 5 years ago by Christian Franke

Milestone: Release 6.4

Please check the ticket resolution. It should possibly be "wontfix" or "worksforme".

comment:13 Changed 5 years ago by Alex Samorukov

Resolution: fixed
Status: closedreopened

comment:14 Changed 5 years ago by Alex Samorukov

Resolution: wontfix
Status: reopenedclosed
Note: See TracTickets for help on using tickets.