Opened 10 years ago

Closed 10 years ago

#3 closed defect (fixed)

ABEND on FreeBSD when non-SCSI device accessed with -d scsi

Reported by: Dan Lukes Owned by: somebody
Priority: trivial Milestone: Experimental Release 5.39
Component: all Version:
Keywords: FreeBSD abend Cc: ml@…

Description

Try

smartctl -d scsi /dev/ad0

Bug in os_freebsd.cpp
con->devname == NULL when used in cam_open_spec_device()

more detailed analysis required but not done yet.

Attachments (1)

os_freebsd.patch (2.3 KB) - added by Alex Samorukov 10 years ago.
fix -d <type> on freebsd

Download all attachments as: .zip

Change History (4)

comment:1 Changed 10 years ago by Alex Samorukov

I think that the problem is in the open() function. It recognizes type of the device and ignore -d switch on it. So it uses procedure for ATA drive and not for scsi.

comment:2 Changed 10 years ago by Alex Samorukov

Yes, found the reason. It tries to autodetect smart device (using parse_ata_chan_dev) if -d scsi is set. The code should be rewritten to get off parse_ata_chan_dev and to switch only to autodetect_smart_device. I will try to do this.

Changed 10 years ago by Alex Samorukov

Attachment: os_freebsd.patch added

fix -d <type> on freebsd

comment:3 Changed 10 years ago by Alex Samorukov

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.