Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#283 closed defect (fixed)

problem with smartctl -a with SDM SSD memory device

Reported by: jeremy385892 Owned by: somebody
Priority: major Milestone: Release 6.2
Component: drivedb Version: 6.1
Keywords: Cc:

Description

I execute smartctl -a on a SATA-Disk Module SSD memory in freebsd 8.2 platform (with smartmontools 6.1) and and I have the following error with smartctl -a on this memory device:

START OF INFORMATION SECTION

Device Model: 2GB SATA Flash Drive
Serial Number: 00101082267000105015
Firmware Version: SFI2101D
User Capacity: 1,982,324,736 bytes [1.98 GB]
Sector Size: 512 bytes logical/physical
Rotation Rate: Solid State Device
Device is: Not in smartctl database [for details use: -P showall]
ATA Version is: ATA8-ACS, ATA/ATAPI-4 published, ANSI NCITS 317-1998
SATA Version is: SATA 2.6, 3.0 Gb/s
Local Time is: Tue Jun 25 11:25:48 2013 GMT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

START OF READ SMART DATA SECTION

SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status: (0x00) Offline data collection activity

was never started.
Auto Offline Data Collection: Disabled.

Self-test execution status: ( 0) The previous self-test routine completed

without error or no self-test has ever
been run.

Total time to complete Offline
data collection: ( 1) seconds.
Offline data collection
capabilities: (0x75) SMART execute Offline immediate.

No Auto Offline data collection support.
Abort Offline collection upon new
command.
No Offline surface scan supported.
Self-test supported.
Conveyance Self-test supported.
Selective Self-test supported.

SMART capabilities: (0x0003) Saves SMART data before entering

power-saving mode.
Supports SMART auto save timer.

Error logging capability: (0x01) Error logging supported.

No General Purpose Logging support.

Short self-test routine
recommended polling time: ( 1) minutes.
Extended self-test routine
recommended polling time: ( 1) minutes.
Conveyance self-test routine
recommended polling time: ( 1) minutes.

SMART Attributes Data Structure revision number: 7
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE

12 Power_Cycle_Count 0x0200 100 100 000 Old_age Offline - 11

160 Unknown_Attribute 0x0200 100 100 000 Old_age Offline - 0
161 Unknown_Attribute 0x0200 100 100 000 Old_age Offline - 0
162 Unknown_Attribute 0x0200 100 100 000 Old_age Offline - 151
163 Unknown_Attribute 0x0200 100 100 000 Old_age Offline - 9
164 Unknown_Attribute 0x0200 100 100 000 Old_age Offline - 5
165 Unknown_Attribute 0x0200 100 100 000 Old_age Offline - 5
241 Total_LBAs_Written 0x0200 100 100 000 Old_age Offline - 16573426

ad0: FAILURE - SMART status=51<READY,DSC,ERROR> error=4<ABORTED>
Read SMART Error Log failed: request failed, error code 0x05

ad0: FAILURE - SMART status=51<READY,DSC,ERROR> error=4<ABORTED>
Read SMART Self-test Log failed: request failed, error code 0x05

ad0: FAILURE - SMART status=51<READY,DSC,ERROR> error=4<ABORTED>
Read SMART Selective Self-test Log failed: request failed, error code 0x05

Attachments (1)

smartctl (3.7 KB) - added by jeremy385892 6 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 in reply to:  description Changed 6 years ago by Christian Franke

Component: alldrivedb

Device Model: 2GB SATA Flash Drive

Any info about the vendor of the device?

12 Power_Cycle_Count 0x0200 100 100 000 Old_age Offline - 11

160 Unknown_Attribute 0x0200 100 100 000 Old_age Offline - 0

Is there any SMART Spec available for this device?

Error logging capability: (0x01) Error logging supported.

No General Purpose Logging support.

This device reports error logging capability, but ...

ad0: FAILURE - SMART status=51<READY,DSC,ERROR> error=4<ABORTED>
Read SMART Error Log failed: request failed, error code 0x05

... the actual read log command is apparently not implemented. This is a minor firmware bug, not a smartctl problem.

comment:2 Changed 6 years ago by jeremy385892

The device is the following:
APSDM002G15AN-CT from Apacer

comment:3 Changed 6 years ago by Alex Samorukov

I think that i found specs (http://www.mouser.com/ds/2/24/2011121417425987-371.pdf):

5.6 S.M.A.R.T.
S.M.A.R.T. is an acronym for Self-Monitoring, Analysis and Reporting Technology, an open standard allowing disk drives to automatically monitor their own health and report potential problems. It protects the user from unscheduled downtime by monitoring and storing critical drive performance and calibration parameters. Ideally, this should allow taking proa
ctive actions to prevent impending drive failure.
Apacer SDM4 uses the standard SMART command B0h to read data from the drive for SMART feature
as the SATA Rev.2.6 ATA/ATAPI-7 specifications. Based on the SFF-8035i Rev. 2.0 specifications, Apacer SMART defines vendor-specified SMART Attribut
e IDs (A0h, A1h, A2h, A3h, A4h-A5h) in SDM4.
They represent initial back block count, bad block count, spare block count, maximum erase count, and average erase counts respectively. When the Apacer SMART Utility running on the host, it analyzes and reports the disk status to the host before SDM4 is in critical condition

comment:4 Changed 6 years ago by Alex Samorukov

So, in the table:

160 (0xA0) -  initial back (bad) block count (?)
161 (0xA1) -  bad block count
162 (0xA2) -  spare block count
163 (0xA3) -  maximum erase count
164 (0xA3) -  avg erase count
165 (0xA3) -  avg erase count (?)

Also document lists all possible id`s (APSDMxxxx15Ax-AXX) so we can add this to database. What is still unclear for me, what is ATA ID block for this device?

Changed 6 years ago by jeremy385892

Attachment: smartctl added

comment:5 Changed 6 years ago by jeremy385892

For information, the result of smarctl -x on the device memory is attached.

comment:6 Changed 6 years ago by Alex Samorukov

Your disk added to the smartctl database. Please check if it works for you. About failures during smartctl run - it is safe to ignore them.
Please check if database record works for you and let me know, thanks.

comment:7 Changed 6 years ago by jeremy385892

Thank you for smartctl database improvement, it works.

But I would want to understand also the reason of failures during smartctl execution to solve it.
ad0: FAILURE - SMART status=51<READY,DSC,ERROR> error=4<ABORTED>
Read SMART Error Log failed: request failed, error code 0x05

What is the causes of this problem ?

comment:8 Changed 6 years ago by Alex Samorukov

This error is caused by drive firmware, which returns error to one of the commands. Try to run

smartctl -a -r ioctl

to find what exactly causing this error message. But from my point of view it is safe to ignore it. You may also want to try smartctl -a -F nologdir to see if it works for you.

comment:9 Changed 6 years ago by jeremy385892

smartctl -a -F nologdir returns the same failure as smartctl -a

smartctl -a -r ioctl returns:

REPORT-IOCTL: Device=/dev/ad0 Command=SMART READ LOG InputParameter?=1

Input: FR=0xd5, SC=0x01, LL=0x01, LM=0x4f, LH=0xc2, DEV=...., CMD=0xb0 IN
[Duration: 0.001s]

REPORT-IOCTL: Device=/dev/ad0 Command=SMART READ LOG returned -1 errno=5 [request failed, error code 0x05]
Read SMART Error Log failed: request failed, error code 0x05

But smartctl -a returns a line which indicates:
Error logging capability: (0x01) Error logging supported.

So if this capability is supported by the device, why is it failed during execution ?

comment:10 Changed 6 years ago by Alex Samorukov

Because of bug in SDD firmware ) It is reported as supported but in fact - not.

comment:11 Changed 6 years ago by Alex Samorukov

Resolution: fixed
Status: newclosed

Added in r3822

comment:12 Changed 6 years ago by Christian Franke

Milestone: Release 6.2
Note: See TracTickets for help on using tickets.