Opened 8 years ago

Closed 8 years ago

#247 closed defect (fixed)

Unable to get data from SCSI disk on FreeBSD with LSI RAID

Reported by: yuzhaninov Owned by: Alex Samorukov
Priority: major Milestone: Release 6.1
Component: all Version: 6.0
Keywords: megaraid freebsd Cc: Alex Samorukov

Description

After upgrading smartmontools from 5.42 to 6.0 smartd with DEVICESCAN in smartd.conf

smartd -r ioctl,3 -d don't show any ioctls, just:

smartd 6.0 2012-10-10 r3643 [FreeBSD 8.3-STABLE-20121101 amd64] (local build)
Copyright (C) 2002-12, Bruce Allen, Christian Franke, www.smartmontools.org

Opened configuration file /usr/local/etc/smartd.conf
Configuration file /usr/local/etc/smartd.conf was parsed, found DEVICESCAN, scanning devices
In the system's table of devices NO devices found to scan
Unable to monitor any SMART enabled devices. Try debug (-d) option. Exiting...

smartd -r ioctl,2 -d output from version 5.42 is attached.

Some info about hardware:

# camcontrol devlist
<TOSHIBA MK2001TRKB 0105>          at scbus0 target 6 lun 0 (pass0)
<TOSHIBA MK2001TRKB 0105>          at scbus0 target 7 lun 0 (pass1)
<TOSHIBA MK2001TRKB 0105>          at scbus0 target 8 lun 0 (pass2)

(pass diveces created by mfip kernel module)

RAID controller - Supermicro SMC2108 (seems to be LSI MegaRAID SAS 9260)

Attachments (3)

version_5.42.log (25.5 KB) - added by yuzhaninov 8 years ago.
smartd -r ioctl,2 -d output from version 5.42
smartd-6.0-no-patch.txt (2.7 KB) - added by yuzhaninov 8 years ago.
version 6.0, no port patches: smartd -r ioctl,3 -d
smartctl-6.0.txt (3.7 KB) - added by yuzhaninov 8 years ago.
version 6.0, no port patches: smartctl -r ioctl,3 -i /dev/pass1

Download all attachments as: .zip

Change History (12)

Changed 8 years ago by yuzhaninov

Attachment: version_5.42.log added

smartd -r ioctl,2 -d output from version 5.42

comment:1 Changed 8 years ago by yuzhaninov

One more problem on this hardware with smartmontools 6.0 - device type don't detected:

# smartctl -r ioctl,2 -a /dev/pass1
smartctl 6.0 2012-10-10 r3643 [FreeBSD 8.3-STABLE-20121101 amd64] (local build)
Copyright (C) 2002-12, Bruce Allen, Christian Franke, www.smartmontools.org

/dev/pass1: Unable to detect device type
Please specify device type with the -d option.

Use smartctl -h to get a usage summary

In 5.42 smarctl work on this hardware.

comment:2 Changed 8 years ago by Christian Franke

Component: smartdall
Keywords: megaraid added
Milestone: Release 6.1
Version: 5.426.0

comment:3 Changed 8 years ago by Christian Franke

Cc: Alex Samorukov added

Regression was probability introduced by the changes for symlink dereferencing (r3472, r3473).

See all changes in os_freebsd.cpp from 5.42 to 6.0.

comment:4 Changed 8 years ago by Alex Samorukov

No it is not caused by this, but by local and incorrect patch in FreeBSD port. Please try version from SVN it should work fine. Don`t forget to report your results.

comment:5 Changed 8 years ago by yuzhaninov

I have build smartmontools without patch - smartctl now works with pass diveces, but smartd still can't find devices.

Changed 8 years ago by yuzhaninov

Attachment: smartd-6.0-no-patch.txt added

version 6.0, no port patches: smartd -r ioctl,3 -d

comment:6 Changed 8 years ago by Alex Samorukov

Owner: changed from somebody to Alex Samorukov
Status: newaccepted

Device: /dev/pass0, not a disk like device [PDT=0x1f], skip

I think i know whats going on. Could you please try smartctl on this specific device? I think that FreeBSD changing disk type to avoid exporting this pseudo-devices as real (adX) drives and this causing this issue. If you can provide me access to the affected server i can try to do workaround

Changed 8 years ago by yuzhaninov

Attachment: smartctl-6.0.txt added

version 6.0, no port patches: smartctl -r ioctl,3 -i /dev/pass1

comment:7 Changed 8 years ago by Alex Samorukov

Summary: [regression] DEVICESCAN don't work in version 6.0 on FreeBSD with LSI RAIDUnable to get data from SCSI disk on FreeBSD with LSI RAID

comment:8 Changed 8 years ago by Alex Samorukov

initial bug was result of the outdated patch in the FreeBSD port. but also it was found that mfip driver changing PDT value of the device from 00h to 1fh what making problems for smartd/smartctl. Proposed patch to os_freebsd.cpp sent by an email, waiting for feedback.

comment:9 Changed 8 years ago by Alex Samorukov

Resolution: fixed
Status: acceptedclosed

fixed in r3674

Note: See TracTickets for help on using tickets.