Opened 10 years ago

Closed 7 years ago

#21 closed enhancement (fixed)

not able to pull stats from drives attached to areca 1680 controllers

Reported by: stevecs Owned by: ballen4705
Priority: minor Milestone: Release 5.43
Component: all Version: 5.39
Keywords: areca linux Cc:

Description

I have sata & sas drives attached to areca 1680ix controllers and am not able to pull any data from the drives. I used to have sata drives attached to areca 1280ml's when on those I was able to. Seems the program 1) does not recognize the newer 1.47 firmware and 2) can't pull data from the controller. This is being run under ubuntu 8.04.3 64bit.

I would be willing to test any non destructive patches if you do not have access to an areca 1680ix controller.


stcost@loki:/var/log/arecadiskstat/2009$ sudo /var/ftp/pub/incoming/src/sm5/smartctl --all --device=areca,1 /dev/sg11
smartctl 5.39 2009-01-21 22:33 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-8 by Bruce Allen, http://smartmontools.sourceforge.net

The firmware of your Areca RAID controller appears to be outdated!
Please update your controller to firmware version 1.46 or later.
You may download it here: ftp://ftp.areca.com.tw/RaidCards/BIOS_Firmware

Smartctl: Device Read Identity Failed (not an ATA/ATAPI device)


Some sample data from Areca's CLI program from within linux.
---
The System Information
===========================================
Main Processor : 1200MHz
CPU ICache Size : 32KB
CPU DCache Size : 32KB
CPU SCache Size : 512KB
System Memory : 2048MB/533MHz/ECC
Firmware Version : V1.47 2009-07-16
BOOT ROM Version : V1.47 2009-06-25
Serial Number : Y820CABWAR800096
Controller Name : ARC-1680
Current IP Address : 172.18.9.17
===========================================
GuiErrMsg?<0x00>: Success.
The Hardware Monitor Information
=====================================================
[Controller H/W Monitor]

CPU Temperature : 69 C
Controller Temp. : 63 C
CPU Fan : 2518 RPM
12V : 11.856 V
5V : 5.026 V
3.3V : 3.264 V
DDR-II +1.8V : 1.792 V
PCI-E +1.8V : 1.808 V
CPU +1.8V : 1.824 V
CPU +1.2V : 1.200 V
DDR-II +0.9V : 0.896 V
Battery Status : 100%

[Enclosure#1 : ARECA SAS RAID AdapterV1.0]
[Enclosure#2 : ARC-8011x28-01.00.05.08 000 ]
[Enclosure#3 : AIC EI16-53C-01A1 114j]

1.9V : 1.880 V
PSU_0 : OK
PSU_1 : OK
Tmprature_0 : 39 C

[Enclosure#4 : AIC EI16-53C-01A1 114j]

1.9V : 1.890 V
PSU_0 : OK
PSU_1 : OK
Tmprature_0 : 39 C

[Enclosure#5 : AIC EI16-53C-01A1 114j]

1.9V : 1.880 V
PSU_0 : OK
PSU_1 : OK
Tmprature_0 : 40 C

[Enclosure#6 : AIC EI16-53C-01A1 114j]

1.9V : 1.880 V
PSU_0 : OK
PSU_1 : OK
Tmprature_0 : 39 C

=====================================================
GuiErrMsg?<0x00>: Success.
Drive Information
===============================================================
Device Type : SAS(5000C5000B0E7C3E)
Device Location : Enclosure#2 SLOT 21
Model Name : HP DH072BB978
Serial Number : 3PD1V46M0000990
Firmware Rev. : HPD9
Disk Capacity : 73.4GB
Device State : NORMAL
Timeout Count : 0
Media Error Count : 0
Rotation Speed : 15015(RPM)
Device Temperature : 52 C
Read Errors Receovered W/O Delay : 0x0000000000000000
Read Errors Receovered W Delay : 0x0000000000000000
Read Errors Receovered W Retry : 0x0000000000000000
Read Errors Receovered : 0x0000000000000000
Read Total Bytes : 0x0000000000000000
Read Errors Unrecovered : 0x0000000000000000
Write Errors Receovered W/O Delay : 0xFFFFFFFFFFFFFFFF
Write Errors Receovered W Delay : 0x0000000000000000
Write Errors Receovered W Retry : 0x0000000000000000
Write Errors Receovered : 0x0000000000000000
Write Total Bytes : 0x0000000000000000
Write Errors Unrecovered : 0x0000000000000000
Verify Errors Receovered W/O Delay : 0x0000000000000000
Verify Errors Receovered W Delay : 0x0000000000000000
Verify Errors Receovered W Retry : 0x0000000000000000
Verify Errors Receovered : 0x0000000000000000
Verify Errors Unrecovered : 0x0000000000000000
Non-Medium Errors : 0x0000000000000000
===============================================================
GuiErrMsg?<0x00>: Success.
Drive Information
===============================================================
Device Type : SATA(50015B2080005565)
Device Location : Enclosure#3 Disk_01
Model Name : ST31000340NS
Serial Number : 9QJ37BDL
Firmware Rev. : SN06
Disk Capacity : 1000.2GB
Device State : NORMAL
Timeout Count : 0
Media Error Count : 0
SMART Read Error Rate : 84(44)
SMART Spinup Time : 99(0)
SMART Reallocation Count : 100(36)
SMART Seek Error Rate : 76(30)
SMART Spinup Retries : 100(97)
SMART Calibration Retries : N.A.(N.A.)
===============================================================
GuiErrMsg?<0x00>: Success.


Change History (15)

comment:1 Changed 10 years ago by Christian Franke

Component: smartctlall
Milestone: Experimental Release 5.39RC1 5.40

comment:2 Changed 10 years ago by Christian Franke

Milestone: RC1 5.40Stable Release 5.40

comment:3 Changed 10 years ago by Christian Franke

Keywords: linux areca added

comment:4 Changed 10 years ago by Christian Franke

Version: 5.39

comment:5 Changed 10 years ago by ballen4705

Owner: changed from somebody to ballen4705
Status: newassigned

I will try and reproduce this. If I can reproduce I will work with Oliver Bock to fix it.

Since I don't have identical hardware (no SAS disks) could stevecs possibly carry out one test? Namely see if the problem persists with the *earlier* 1.46 firmware version.

comment:6 Changed 10 years ago by ballen4705

Sorry, I have just seen the other correspondence on the smartmontools mailing list. The problem is that SAS drives are not supported. So what needs to be done in the short term is to clean up the error messages, so they say 'SAS drives not currently supported'. I'll take care of this. In the longer term, passing SCSI commands over the interface would be the right approach.

comment:7 Changed 10 years ago by stevecs

For information, yes, the problem happens on V1.46 and V1.47 firmware for the card. As for not supporting SAS drives for smart data polling that should be looked into, however this also happens with SATA drives so no drives when attached to the ARC-1680ix provide smart data.

comment:8 Changed 10 years ago by xiphmont

Hello,

Also on a 1680 here with recent firmware and SATA drives.

motherfishIV:~/smartmontools# ./smartctl -a -d areca,6 /dev/sg1
smartctl 5.40 2010-01-04 r3028 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

The firmware of your Areca RAID controller appears to be outdated!
Please update your controller to firmware version 1.46 or later.
You may download it here: ftp://ftp.areca.com.tw/RaidCards/BIOS_Firmware

Smartctl: Device Read Identity Failed (not an ATA/ATAPI device)

A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.

CLI> disk info

# Enc# Slot# ModelName? Capacity Usage

===============================================================================

1 01 Slot#1 WDC WD1002FBYS-02A6B0 1000.2GB Motherfish RAID
2 01 Slot#2 WDC WD1002FBYS-02A6B0 1000.2GB Motherfish RAID
3 01 Slot#3 WDC WD1002FBYS-02A6B0 1000.2GB Motherfish RAID
4 01 Slot#4 WDC WD1002FBYS-02A6B0 1000.2GB Motherfish RAID
5 01 Slot#5 WDC WD1002FBYS-02A6B0 1000.2GB Motherfish RAID
6 01 Slot#6 WDC WD1002FBYS-02A6B0 1000.2GB Motherfish RAID
7 01 Slot#7 WDC WD1002FBYS-02A6B0 1000.2GB Motherfish RAID
8 01 Slot#8 WDC WD1002FBYS-02A6B0 1000.2GB Motherfish RAID

===============================================================================
GuiErrMsg?<0x00>: Success.

CLI> sys info
The System Information
===========================================
Main Processor : 1200MHz
CPU ICache Size : 32KB
CPU DCache Size : 32KB
CPU SCache Size : 512KB
System Memory : 2048MB/533MHz/ECC
Firmware Version : V1.47 2009-07-16
BOOT ROM Version : V1.46 2009-01-06
Serial Number : Y734CABIAR200166
Controller Name : ARC-1680
Current IP Address : 10.0.1.120
===========================================
GuiErrMsg?<0x00>: Success.

comment:9 Changed 10 years ago by art9

From areca support: there is no support for sas and sata drives for sas controllers with smartmontools, there is no support for smart with areca's CLI and there is no confirmed schedule yet about both.

comment:10 in reply to:  9 Changed 10 years ago by Christian Franke

Milestone: Release 5.40
Resolution: wontfix
Status: assignedclosed

These controllers reportedly do not provide the required pass through support (see previous comment).

comment:11 Changed 9 years ago by Gabriele Pohl

Keywords: linux, arecaareca linux

comment:12 Changed 7 years ago by Christian Franke

Milestone: Release 5.43
Resolution: wontfix
Status: closedreopened
Type: defectenhancement

A patch for SATA drives behind Areca SAS controllers was provided by Areca (Linux: r3540, FreeBSD: r3542). This was also included in the Areca patch for Windows (ticket #175).

Please test current smartctl version from SVN with SATA drives behind a 1680 controller with recent firmware (N=channel or slot, E=enclosure):

  smartctl -x -d areca,N/E /dev/sgX

Please note that SAS drives are still not supported.

comment:13 Changed 7 years ago by stevecs

Unfortunatly I no longer have the ARC1680 cards (the solution had to be scrapped due to this issue and the client couldn't wait for a fix). Hopefully someone else who's watching this issue can test/respond?

comment:14 Changed 7 years ago by Christian Franke

Info from Areca: Access to SATA drives behind Areca SAS controllers works with firmware 1.51 (will be released soon) or a recent beta version.

comment:15 Changed 7 years ago by Christian Franke

Resolution: fixed
Status: reopenedclosed

Linux: r3540, r3541. Also available on FreeBSD and Windows. Requires new Areca firmware, see r3556.

Note: See TracTickets for help on using tickets.