Opened 8 years ago

Closed 5 years ago

#197 closed defect (fixed)

LSI megaraid INQUIRY failed

Reported by: mrambossek Owned by: Alex Samorukov
Priority: major Milestone:
Component: smartctl Version: 5.41
Keywords: megaraid linux Cc:

Description

this might be a duplicate of
https://sourceforge.net/ticket/26
and / or
https://sourceforge.net/ticket/140

but since both offer no working solution and i'm not entirely sure whether its the same issue i'm opening a new ticket.

MegaCli -AdpAllInfo -a0 (condensed)
Adapter #0
==============================================================================
Product Name    : LSI MegaRAID SAS 9260-4i
Serial No       : SV10304594
FW Package Build: 12.11.0-0016
Mfg. Date       : 01/11/11
Rework Date     : 00/00/00
Revision No     : 
Battery FRU     : N/A
FW Version         : 2.110.03-0967
BIOS Version       : 3.18.00_4.09.05.00_0x0416A000
Preboot CLI Version: 04.04-011:#%00008
WebBIOS Version    : 6.0-24-e_19-Rel
NVDATA Version     : 2.08.03-0004
Boot Block Version : 2.02.00.00-0000
BOOT Version       : 01.250.04.219

smartctl from ubuntu 11.10 "oneiric":

smartmontools release 5.41 dated 2011-06-09 at 18:46:32 UTC
smartmontools SVN rev 3365 dated 2011-06-09 at 18:47:31
smartmontools build host: x86_64-unknown-linux-gnu
smartmontools build configured: 2011-06-20 08:55:10 UTC
smartctl compile dated Jun 20 2011 at 08:55:20
smartmontools configure arguments:  '--prefix=/usr' '--sysconfdir=/etc' '--mandir=/usr/share/man' '--with-initscriptdir=/etc/init.d' '--with-docdir=/usr/share/doc/smartmontools' '--enable-drivedb' '--enable-savestates' '--enable-attributelog' '--with-savestates=/var/lib/smartmontools/smartd.' '--with-attributelog=/var/lib/smartmontools/attrlog.' '--with-exampledir=/usr/share/doc/smartmontools/examples/' '--with-selinux' 'CXXFLAGS=-g -O2' 'LDFLAGS=-Wl,-Bsymbolic-functions' 'CPPFLAGS=' 'CFLAGS=-g -O2 -fsigned-char -Wall -O2'

kernel

# ls -al /dev/megaraid_sas_ioctl_node 
cr-------- 1 root root 251, 0 2011-08-29 09:42 /dev/megaraid_sas_ioctl_node
# uname -rv
2.6.38-10-server #46-Ubuntu SMP Tue Jun 28 16:31:00 UTC 2011}}}

# lsscsi -g

[0:2:0:0]    disk    LSI      MR9260-4i        2.11  /dev/sda  /dev/sg0
[1:0:0:0]    disk    ATA      ST31500341AS     CC1H  /dev/sdb  /dev/sg1
[2:0:0:0]    disk    ATA      ST31500341AS     CC1H  /dev/sdc  /dev/sg2
...

the sgX devices with X > 0 are mainboard-connected sata disks in a software raid and thus should be unrelated. the LSI controller has 4 SATA disks connected and is configured to export them as one large virtual drive (RAID5).

these commands i have tried without success (output condensed)

# smartctl -i /dev/sda
Vendor:               LSI
Product:              MR9260-4i
Revision:             2.11
User Capacity:        5,999,532,441,600 bytes [5.99 TB]
Logical block size:   512 bytes
Logical Unit id:      0x600605b00300879015c7068d0f0eaa15
Serial number:        0015aa0e0f8d06c71590870003b00506
Device type:          disk
Local Time is:        Mon Sep 19 11:15:00 2011 CEST
Device does not support SMART

# smartctl -d megaraid,0 -i /dev/sg0                
Smartctl open device: /dev/sg0 [megaraid_disk_00] failed: INQUIRY failed

# smartctl -d megaraid,0 -i /dev/sda
Smartctl open device: /dev/sda [megaraid_disk_00] failed: INQUIRY failed

# smartctl -d megaraid,0 -i /dev/megaraid_sas_ioctl_node
Smartctl open device: /dev/megaraid_sas_ioctl_node [megaraid_disk_00] failed: can't get bus number

# smartctl -d sat+megaraid,1 -i -T permissive /dev/sda 
Smartctl: Device Read Identity Failed: megasas_cmd: Device 1 does not exist

=== START OF INFORMATION SECTION ===
Device Model:     [No Information Found]
Serial Number:    [No Information Found]
Firmware Version: [No Information Found]
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   [No Information Found]
ATA Standard is:  [No Information Found]
Local Time is:    Mon Sep 19 11:13:10 2011 CEST
SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 82-83 don't show if SMART supported.
SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 85-87 don't show if SMART is enabled.
SMART support is: Unknown - Try option -s with argument 'on' to enable it.

any ideas? :(

Change History (6)

comment:1 Changed 8 years ago by Alex Samorukov

Owner: changed from somebody to Alex Samorukov
Status: newaccepted

I think that you are using wrong number. Try megaraid,1 - megaraid,32

comment:2 Changed 8 years ago by Alex Samorukov

Resolution: wontfix
Status: acceptedclosed

No response from user and not enough data to work on this ticket. Closing it.

comment:3 Changed 7 years ago by jonbendtsen

this page showed up in my own search for a solution, so I have decided to leave a note for any future users about what worked for me.

samm2's suggested solution, option 'megaraid,1 - megaraid32' did work for me. When I run 'smartctl -i -d sat+megaraid,2' I do get S.M.A.R.T information.

If I let the ,2 run through a sequence like from 2-14 I do get individual information about all my 12 disks. The Serial Number is different depending on which ,# I ask about.

However, if I keep the ,# static, like ,2 then it does not make any difference if I ask /dev/sda, /dev/sdb, ..., /dev/sdl or /dev/bsg/* I still get the same disk information sole dependent on the ,# part.

This means I can not use smartctl to correlate which disk is sda, sdb, ..., sdl. But it is possible to use "megacli -LdPdInfo? -a0" because one of that commands output lines are "Virtual Drive: 11 (Target Id: 11)" which matches the lsscsi output "[0:2:11:0] disk SMC SMC2108 2.12 /dev/sdl". Another megacli output line is "Device Id: 14" which corresponds to the ,14 number above. The serial number from smartctl ..blabla... ,14 matches with the serial number from both "megacli -LdPdInfo? -a0" and "megacli -pdInfo -PhysDrv?[$encdeviceid:$slotnr] -a$controllernr".

comment:4 Changed 5 years ago by k2chris1983

Resolution: wontfix
Status: closedreopened

I have created a script that allows you to bring up the Target ID, Device ID and the Mount up together.

perform_target() {
    for i in {1}; do MegaCli -LdpdInfo -a0; done |
        awk '/Target Id:/ {printf("%s  ", $3)} /Device Id:/ {print $3}'
}
perform_drive() {
    for h in {1}; do lsscsi; done |
        awk '/MR9260-16i/ {print $6}'
}

# Pasts the info in columns 
paste <(perform_target) <(perform_drive) 

Output should be:

0  104  /dev/sdb
1  113  /dev/sdc
2  210  /dev/sdd
3  211  /dev/sde
4  212  /dev/sdg
5  216  /dev/sdh
6  217  /dev/sdi
7  218  /dev/sdj
8  219  /dev/sdk
9  220  /dev/sdl
10  221 /dev/sdm
11  222 /dev/sdn
12  223 /dev/sdo

So you would type this for smart for Target Zero:

smartctl -S on -a -d megaraid,104 /dev/sdb

Note you may have to mod the script up to work right on your system and may have to install lsscsi.

comment:5 in reply to:  4 Changed 5 years ago by k2chris1983

Replying to k2chris1983:

I have created a script that allows you to bring up the Target ID, Device ID and the Mount up together.

perform_target() {
    for i in {1}; do MegaCli -LdpdInfo -a0; done |
        awk '/Target Id:/ {printf("%s  ", $3)} /Device Id:/ {print $3}'
}
perform_drive() {
    for h in {1}; do lsscsi; done |
        awk '/MR9260-16i/ {print $6}'
}

# Pasts the info in columns 
paste <(perform_target) <(perform_drive) 

Output should be:

0  104  /dev/sdb
1  113  /dev/sdc
2  210  /dev/sdd
3  211  /dev/sde
4  212  /dev/sdg
5  216  /dev/sdh
6  217  /dev/sdi
7  218  /dev/sdj
8  219  /dev/sdk
9  220  /dev/sdl
10  221 /dev/sdm
11  222 /dev/sdn
12  223 /dev/sdo

So you would type this for smart for Target Zero:

smartctl -S on -a -d megaraid,104 /dev/sdb

Note you may have to mod the script up to work right on your system and may have to install lsscsi.

P.S. If you are going to use the script, it maybe wise to put another AWK for the WWN or SN. To ensure you have the right one, etc.

comment:6 Changed 5 years ago by Alex Samorukov

Resolution: fixed
Status: reopenedclosed

Recent smartmontools supports --scan-open for the devices on the megaraid controller. Please use this instead.

Note: See TracTickets for help on using tickets.