Opened 10 years ago

Closed 7 years ago

#19 closed defect (wontfix)

smartmontools-5.38 repeatedly freeze Macbook (OS X)

Reported by: jensb Owned by: cooties
Priority: major Milestone:
Component: smartd Version: 5.38
Keywords: macosx Cc:

Description

When I install smartmontools via MacPorts? (default build), the 'smartd' daemon is automatically registered as a StartupItem?. After that, it will periodically - every 30 minutes - query my harddisk and log the following:

Oct 14 00:38:05 Schleppmich smartd[50]: Device: IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@B/AppleMCP79AHCI
PRT0@0/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice, failed to read SMART Attribute Data

during which my computer freezes for about five to ten seconds (possibly because not HDD access is possible). Removing smartmontools and killing smartd also stopped the repeated freeze.

Issue: Querying SMART attributes should not freeze the computer (I am running several Linux machines where smartmontools and smartd work fine without freeze).

Hardware:

  Modellname:	MacBook Pro
  Modell-Identifizierung:	MacBookPro5,5
  Prozessortyp:	Intel Core 2 Duo
  Prozessorgeschwindigkeit:	2,26 GHz
  Anzahl der Prozessoren:	1
  Gesamtzahl der Kerne:	2
  L2-Cache:	3 MB
  Speicher:	2 GB
  Busgeschwindigkeit:	1,07 GHz
  Boot-ROM-Version:	MBP55.00AC.B03
  SMC-Version (System):	1.47f2

Harddisk:

  Kapazität:	500,11 GB (500.107.862.016 Byte)
  Modell:	WDC WD5000BEVT-22ZAT0                   
  Version:	01.01A01
  Seriennummer:	     WD-WXB0A8948221
  Native Command Queuing:	Ja
  Queue Depth:	32
  Wechselmedien:	Nein
  Absteckbares Laufwerk:	Nein
  BSD-Name:	disk0
  Rotationsrate:	5400
  Partitionstabellentyp:	GPT (GUID-Partitionstabelle)
  S.M.A.R.T.-Status:	Überprüft

Also, 'smartctl' will report SMART as "disabled" when querying the disk, although OS X reports the SMART status as 'OK'.

Change History (12)

comment:1 Changed 10 years ago by Christian Franke

Version: 5.38

comment:2 Changed 10 years ago by geoffk1

What does 'pmset -g' display? Is 'disksleep' set to less than 30 minutes? If so, turn it off ('sudo pmset -a disksleep 0'), so that the disk does not go to sleep.

comment:3 Changed 10 years ago by Dan Lukes

Can you try it with 5.39 release, please ? I don't think it will work, but it would be nice to know the problem is still here.

comment:4 Changed 10 years ago by bobbaer2

Some additional information from my side:

  • problem started with 10.6.x; 5.38 was running fine in Tiger/10.4.x (5.39 never tested in 10.4)
  • problem occurs with 5.38 and 5.39 in 10.6.x
  • problem occurs with disksleep (pmset -g) disabled for all profiles (battery and AC)
  • changing smartd.conf from DEVICESCAN to something more specific like /dev/disk0 -a -o on -S on did not make any difference
  • getting the same alert as above: [...]smartd[4027]: Device: IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@1F,2/AppleAHCI/PRT2@2/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice, failed to read SMART Attribute Data
  • I don't experience the freezing every time it's logged
  • If the problem occurs, smartctl -a disk0 will fail with SMART support is: Available - device has SMART capability. SMART support is: Disabled

--> this can be turned on again with smartctl --smart=on --saveauto=on disk0

  • even when the problem occurs, smartd -q onecheck is still working; afterwards smartctl -a disk0" will run again:

smartd 5.39 2009-12-09 r2995 [i386-apple-darwin10.2.0] (local build)
Copyright (C) 2002-9 by Bruce Allen, http://smartmontools.sourceforge.net
Opened configuration file /usr/local/smartmontools/etc/smartd.conf
Drive: DEVICESCAN, implied '-a' Directive on line 23 of file /usr/local/smartmontools/etc/smartd.conf
Configuration file /usr/local/smartmontools/etc/smartd.conf was parsed, found DEVICESCAN, scanning devices
Device: IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@1F,2/AppleAHCI/PRT2@2/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice, opened
Device: IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@1F,2/AppleAHCI/PRT2@2/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice, found in smartd database.
Device: IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@1F,2/AppleAHCI/PRT2@2/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice, is SMART capable. Adding to "monitor" list.
Monitoring 1 ATA and 0 SCSI devices
Device: IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@1F,2/AppleAHCI/PRT2@2/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice, opened ATA device
Started with '-q onecheck' option. All devices sucessfully checked once.
smartd is exiting (exit status 0)

smartctl -a disk0
[…]
smartctl 5.39 2009-12-09 r2995 [i386-apple-darwin10.2.0] (local build)
Copyright (C) 2002-9 by Bruce Allen, http://smartmontools.sourceforge.net
START OF INFORMATION SECTION ===
[…]
SMART support is: Available - device has SMART capability.
SMART support is: Enabled
START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED
[…]

--> Looks like SMART is being disabled after a while? Hoping for a fix with 10.6.3ff. or within smartmontools.

comment:5 Changed 10 years ago by geoffk1

I think I've seen this before, some other piece of software was disabling SMART occasionally. My memory is fuzzy, but I think it was some kind of disk monitoring or backup utility, perhaps Norton something? Do you have any other disk monitoring or backup tools installed?

comment:6 Changed 10 years ago by bobbaer2

No backup software or norton or whatsoever.
I found iStat Menus was monitoring the SMART-temperature as well. As the general check interval is set to 60min this could explain why I only got errors every 60 min though smartd was set to default (30min).

A little test seems to confirm that this may be the culprit:
the moment I activate monitoring of smart drive temp in iStat Menus, smartctl -a disk0 fails (smart disabled). Once monitoring is deactivated and smart again enabled, it seems to be stable.

I will have to monitor the behaviour of the machine now smart disk temp monitoring is deactivated.

comment:7 Changed 10 years ago by bobbaer2

no more errors logged from smartd since disabling disk temp monitoring in iStat Menus.
Maybe this alert should be in the FAQ together with a more or less specific list of applications to check.

I haven't seen the freezes so far the orignal poster complained about, so this ticket may still be valid if our problems are not related.

comment:8 Changed 9 years ago by cooties

Owner: changed from somebody to cooties
Status: newaccepted

comment:9 Changed 9 years ago by Christian Franke

Keywords: macosx added; osx freeze smartd removed

comment:10 Changed 9 years ago by arcadiclife

I almost took my Mac into the Genius bar because I had forgotten I had installed smartmontools (also via MacPorts?), and I was getting 30 second freezes every 30 minutes. Took me a few weeks to figure it out, since I thought smartd was part of OS X and thus I was ignoring the syslog entries. Stupid thinking in retrospect, but glad to have figured it out.

I didn't get the freezes in 10.5, but do in 10.6.x (seen in 10.6.4 and 10.6.5).

Here's the log entry I was getting with the freezes:
Nov 11 10:02:01 isabel smartd[60]: Device: IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@B/AppleMCP79AHCI/PRT0@0/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice, failed to read SMART Attribute Data

I also have iStat Pro dashboard widget installed, and the only backup software I use is Time Machine. I have disk sleep disabled on this computer.

comment:11 Changed 7 years ago by Christian Franke

Is the problem reproducible with smartmontools 6.0 and current versions of OS X ?

comment:12 Changed 7 years ago by Christian Franke

Resolution: wontfix
Status: acceptedclosed

Smartmontools 5.38 is now more than 4 years old. There was no similar problem report since Nov 2010. The kernel error messages suggest that this is a OS X kernel/driver problem that we cannot fix.

Please reopen this ticket if the problem could be reproduced with smartmontools 6.0 on a recent OS X version.

Note: See TracTickets for help on using tickets.