Opened 7 weeks ago

Closed 7 weeks ago

Last modified 7 weeks ago

#1827 closed defect (duplicate)

Read Self-test Log failed: Invalid Field in Command (0x4002)

Reported by: Artem S. Tashkinov Owned by:
Priority: major Milestone: Release 7.5
Component: smartctl Version: 7.4
Keywords: nvme Cc:

Description

smartctl 7.4 2023-08-01 r5530 fails to read the Self-test Log and seemingly fails to start any short/long self tests with the same error.

Sorry if it's already been reported but I've not been able to find any similar reports.

My device is:

Model Number: WD_BLACK SN770 1TB
Firmware Version: 731100WD

Change History (3)

comment:1 by Christian Franke, 7 weeks ago

Keywords: nvme added
Milestone: undecided

If namespace 1 was used, please retry with broadcast namespace or with a recent CI build from https://builds.smartmontools.org/

If this works, this ticket is a duplicate of ticket #1741.

comment:2 by Artem S. Tashkinov, 7 weeks ago

Resolution: duplicate
Status: newclosed

Yeah, it's a dupe, it all works when I don't specify the namespace.

Weirdly it used to work with smartmontools 7.3 or maybe I misremember.

comment:3 by Christian Franke, 7 weeks ago

Milestone: undecidedRelease 7.5

NVMe self-test support is a new feature of smartmontools 7.4.

Note: See TracTickets for help on using tickets.