Opened 7 months ago

Last modified 7 months ago

#1773 new enhancement

smartctl --scan can not detect the disks behind a megaraid controller on Dell Poweredge R620 with windows os

Reported by: kate Owned by:
Priority: minor Milestone: undecided
Component: all Version: 7.3
Keywords: lsi megaraid windows Cc:

Description (last modified by Christian Franke)

I have a Dell PowerEdge 620 server. It was provisioned with linux os.
I installed linux version of smartmontools on it.
the smartctl --scan command showed following output

/dev/sda -d scsi # /dev/sda, SCSI device
/dev/bus/0 -d megaraid,0 # /dev/bus/0 [megaraid_disk_00], SCSI device
/dev/bus/0 -d megaraid,1 # /dev/bus/0 [megaraid_disk_01], SCSI device
/dev/bus/0 -d megaraid,2 # /dev/bus/0 [megaraid_disk_02], SCSI device
/dev/bus/0 -d megaraid,3 # /dev/bus/0 [megaraid_disk_03], SCSI device

The first line indicates a raid controller and the next 4 lines represent the disks behind the raid controller. It is a megaraid type controller.

Then running
smartctl -a -d megaraid,0 /dev/bus/0
showed all the details about first disk including serial number, model, size etc and also all the smart parameters.

Now I installed windows os on the same server. Also installed windows release 7.3 of smartmontools.
But on windows smartctl --scan does not show the disks. The output only shows one line.
/dev/sda -d scsi # /dev/sda, SCSI device

If I run
smartctl -a -d megaraid,0 /dev/bus/0
I get an error as below


smartctl 7.3 2022-02-28 r5338 [x86_64-w64-mingw32-2022-21H2] (sf-7.3-1)
Copyright (C) 2002-22, Bruce Allen, Christian Franke, www.smartmontools.org
/dev/bus/0: Unknown device type 'megaraid,0'
=======> VALID ARGUMENTS ARE: ata, scsi[+TYPE], nvme[,NSID], sat[,auto][,N][+TYPE], usbcypress[,X], usbjmicron[,p][,x][,N], usbprolific, usbsunplus, sntasmedia, sntjmicron[,NSID], sntrealtek, intelliprop,N[+TYPE], jmb39x[-q],N[,sLBA][,force][+TYPE], jms56x,N[,sLBA][,force][+TYPE], aacraid,H,L,ID, areca,N[/E], auto, test <=======
Use smartctl -h to get a usage summary 

On the same server linux version of smartctl can see the disks behind the raid controller but windows version of smartctl says

Unknown device type 'megaraid,0'

What do I need to do to get the windows version of smartctl to detect and show the smart parameters of the disks controlled a by a raid controller.

Are there any other versions / settings or commands that I need to run so as to detect the raided disks on windows?

If it is a bug can you fix it?

Change History (2)

comment:1 by Christian Franke, 7 months ago

Description: modified (diff)

comment:2 by Christian Franke, 7 months ago

Component: smartctlall
Keywords: lsi megaraid windows added
Milestone: undecided
Priority: blockerminor
Type: defectenhancement

In general, RAID controller support is controller and platform specific, please see the related Wiki page.

man smartctl on Linux says:

   megaraid,N  -  [FreeBSD  and  Linux  only] the device consists of one or more SCSI/SAS disks ...

Therefore this section is not present on the Windows version of the man page.

If CrystalDiskInfo works with this controller, then this ticket is a duplicate of ticket #1322. If not, this ticket will be closed as wontfix unless someone provides the required documentation.

Note: See TracTickets for help on using tickets.