Opened 8 years ago

Closed 8 years ago

#174 closed defect (fixed)

Warning email text is truncated on Windows 7

Reported by: Christian Franke Owned by: Christian Franke
Priority: major Milestone: Release 5.41
Component: smartd Version: 5.40
Keywords: windows Cc:

Description

When smartd sends a warning email on Windows 7 its text is truncated:

This email was generated by the smartd daemon running on:

    host name: somehost
   DNS domain: somedomain

missing:

The following warning/error was logged by the smartd daemon:

TEST EMAIL from smartd for device: /dev/sda

For details see the event log or log file of smartd. 

Problem does not occur on Windows XP.

Change History (2)

comment:1 Changed 8 years ago by Christian Franke

Milestone: Release 5.41
Owner: changed from somebody to Christian Franke
Status: newaccepted

The root of the problem is that the printf() formatting in the msvcrt.dll now disables "%n" support by default. This was initially added in msvcrt8.dll and later and was apparently later backported to the msvcrt.dll on Win7 (and likely Vista) but not on XP. MinGW builds use the msvcrt.dll by default. Smartd calls _set_printf_count_output(1) only for MSVC builds. Use of "%n" should be avoided.

comment:2 Changed 8 years ago by Christian Franke

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.