Opened 10 months ago

Closed 2 months ago

#1739 closed enhancement (fixed)

Support more SK Hynix drives in drivedb.h (HFS480G32FEH-BA10A)

Reported by: Anthony D'Atri Owned by: Christian Franke
Priority: minor Milestone: Release 7.5
Component: drivedb Version: 7.4
Keywords: ssd Cc:

Description

This entry is unnecessarily restrictive:

HFS(480|960|1T9|3T8)G3[2E]FEH-7[4A]10A", tested with HFS480G32FEH-7410A/90037Q00

Replace -7[4A]10A with .* to match other variants.
If that is not acceptable, I've included also a diff to match HFS480G32FEH-BA10A explicitly.

Attachments (5)

diff-precise-u.txt (526 bytes ) - added by Anthony D'Atri 10 months ago.
diff-precise-c.txt (745 bytes ) - added by Anthony D'Atri 10 months ago.
diff-u.txt (430 bytes ) - added by Anthony D'Atri 10 months ago.
diff-c.txt (648 bytes ) - added by Anthony D'Atri 10 months ago.
hynix.txt (9.4 KB ) - added by Anthony D'Atri 9 months ago.

Download all attachments as: .zip

Change History (14)

by Anthony D'Atri, 10 months ago

Attachment: diff-precise-u.txt added

by Anthony D'Atri, 10 months ago

Attachment: diff-precise-c.txt added

by Anthony D'Atri, 10 months ago

Attachment: diff-u.txt added

by Anthony D'Atri, 10 months ago

Attachment: diff-c.txt added

comment:1 by Anthony D'Atri, 10 months ago

HFS480G32FEH-BA10A is the only variant I have, and I've been unable to find an SK decoder to discern which others might exist. Replacing the hyphenate suffix with a wildcard seems appropriate in this case.

comment:2 by Christian Franke, 10 months ago

Component: alldrivedb
Keywords: ssd added; drivedb.h removed
Milestone: unscheduled
Summary: Support more SK Hynix drives in drivedb.hSupport more SK Hynix drives in drivedb.h (HFS480G32FEH-BA10A)

Thanks. Please provide a smartctl -x [-q noserial] ... output for the device variant you have.

PS: It is not needed to provide patches also in traditional context diff format (default for diff). The unified diff format (diff -u, default for git diff and svn diff) is IMO easier to read and the de facto standard to distribute patches.

by Anthony D'Atri, 9 months ago

Attachment: hynix.txt added

comment:3 by Anthony D'Atri, 9 months ago

Attached. I couldn't remember which diff style you prefer.

comment:4 by Christian Franke, 2 months ago

Milestone: unscheduledRelease 7.5
Owner: set to Christian Franke
Status: newaccepted

comment:5 by Anthony D'Atri, 2 months ago

Danke. I tried hard to find a SMART reference for this SKU. Contacts inside Solidigm even thought this product had been cancelled -- but here it is. I'd implemented editing drivedb.h in-situ on my fleet pending this, now I can remove that after 7.5 is released.

comment:6 by Christian Franke, 2 months ago

Ticket #1805 (1TB model) has been marked as a duplicate of this ticket.

comment:7 by Christian Franke, 2 months ago

Ticket #1809 (1TB model) has been marked as a duplicate of this ticket.

comment:8 by Christian Franke, 2 months ago

Ticket #1758 has been marked as a duplicate of this ticket.

comment:9 by Christian Franke, 2 months ago

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.