Opened 4 months ago

Closed 4 months ago

#1693 closed defect (invalid)

"SMART support is:" missing

Reported by: karaka Owned by:
Priority: critical Milestone:
Component: smartctl Version: 7.3
Keywords: nvme Cc:

Description

Hello,

I am using version 7.3 version of smartmontools on Leap 15.4. I have ran "update-smart-drivedb" after installation.
I have 2 HDDs and 1 NVMe SSD CT250P2SSD8, which seems to be supported.

When I run "smartctl -a /dev/nvme0" or "smartctl -i /dev/nvme0n1" there is no mention of the two "SMART support is:" lines.

Attachments (2)

smart-i2.txt (864 bytes) - added by karaka 4 months ago.
smartctl -i
smart-a2.txt (2.8 KB) - added by karaka 4 months ago.
smartctl -a

Download all attachments as: .zip

Change History (5)

Changed 4 months ago by karaka

Attachment: smart-i2.txt added

smartctl -i

Changed 4 months ago by karaka

Attachment: smart-a2.txt added

smartctl -a

comment:1 Changed 4 months ago by karaka

The HDD outputs have the two lines, but my SSD disk output doesn´t.
I can run and see results of my SMART info/tests using smartmontools. No problem here.

Some more bg info: I am relying on this output to discern whether my disks have SMART capabilities or not.

Am I using smartmontool as intended, or do you suggest using a different, more reliable way to check for SMART capabilities of any disk?

Thanks!

comment:2 Changed 4 months ago by Christian Franke

Keywords: nvme added

SMART related information of ATA/SATA, NVMe and SCSI/SAS differ considerably an so do smartctl outputs.

This SSD is a NVMe SSD and your HDD is likely a SATA HDD. The output for NVMe does not contain SMART support is: ... because, unlike SATA, the related functionality (SMART/Health Information) is mandatory and cannot be disabled.

comment:3 Changed 4 months ago by Christian Franke

Resolution: invalid
Status: newclosed

This is a NVMe SSD and smartctl output is as expected. See above comment for details.

Note: See TracTickets for help on using tickets.