Opened 8 years ago

Closed 8 years ago

#167 closed enhancement (fixed)

Resend warning email when a problem reappears

Reported by: Christian Franke Owned by: Christian Franke
Priority: minor Milestone: Release 5.42
Component: smartd Version: 5.40
Keywords: Cc:

Description

If a problem is detected the first time, smartd sends only one warning email and possibly later optional (e.g. -M daily) reminder emails if the problem persists or reappears.

If the problem is no longer detected this state should be reset such that another email is always sent immediately when the problem is detected again:

-C ID -U ID: Reset if number of pending or uncorrectable sectors drops to 0. This typically happens when all known bad sectors have been reallocated.

-l selftest: Reset if number of failed self-tests drops to 0. Since r3272 this happens when an extended self-test is run after all bad sectors have been reallocated.

-W DIFF,INFO,CRIT: Reset if temperature drops below CRIT minus some reasonable threshold. For example below INFO if set or else below CRIT-DIFF+1 if set or else below CRIT-3.

Change History (3)

comment:1 Changed 8 years ago by Christian Franke

Owner: changed from somebody to Christian Franke
Status: newaccepted

comment:2 Changed 8 years ago by Christian Franke

Milestone: Release 5.42

comment:3 Changed 8 years ago by Christian Franke

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.