Opened 2 months ago

Closed 2 months ago

#1652 closed enhancement (wontfix)

Support for CCISS (HP/Compaq Smart Array Controller) in Windows

Reported by: Csaba Kálmán Owned by:
Priority: minor Milestone:
Component: all Version: 7.3
Keywords: cciss windows Cc:

Description

Hi!

Do you have any information about if this configuration will be supported in the future?
I have a DL360 Gen8 server, with P420i RAID controller.
The smartctl --scan detects devices like:
/dev/csmi2,0 -d ata # /dev/csmi2,0, ATA device

but I cannot get any more information

Read Device Identity failed: CSMI(25) failed with ReturnCode?=2

Attachments (2)

smartctl_scan.txt (5.2 KB) - added by Csaba Kálmán 2 months ago.
smartctl_i.txt (8.5 KB) - added by Csaba Kálmán 2 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 2 months ago by Csaba Kálmán

Component: allsmartctl
Keywords: windows added

comment:2 Changed 2 months ago by Christian Franke

Component: smartctlall
Keywords: cciss added
Milestone: undecided

This usually requires a spec or sample sourcecode from the vendor of the Windows driver for the controller. Could you provide this?

This driver apparently advertises CSMI (Common Storage Management Interface) support. Smartmontools for Windows currently implements CSMI for Intel and AMD SATA RAID only. There is no CSMI SAS support.

Please provide the outputs of

smartctl -r ioctl,2 --scan
smartctl -r ioctl,2 -i /dev/csmi2,0

as plaintext attachments to this ticket.

comment:3 Changed 2 months ago by Christian Franke

Ticket #1516 has been marked as a duplicate of this ticket.

Changed 2 months ago by Csaba Kálmán

Attachment: smartctl_scan.txt added

Changed 2 months ago by Csaba Kálmán

Attachment: smartctl_i.txt added

comment:4 Changed 2 months ago by Csaba Kálmán

Hi!

Thank you for your support! Attached the outputs of the two command.

comment:5 Changed 2 months ago by Christian Franke

CSMI seems incomplete or requires different parameters:

CC_CSMI_SAS_GET_DRIVER_INFO: works.
CC_CSMI_SAS_GET_PHY_INFO: works and reports 6 ports connected to a SATA device and 2 ports unconnected. Is this correct?

CC_CSMI_SAS_GET_RAID_INFO: fails.
CC_CSMI_SAS_STP_PASSTHRU: fails.

The latter is required to access SMART data of SATA devices behind the controller. It is even not known if the driver somehow supports such a function as it is not required for regular I/O.

Unfortunately the available CSMI specs (T10/04-284r0, T11.5/04-468v0) do not provide any help as this standardization effort was apparently discontinued after the early incomplete drafts from 2004.

Is there any vendor specific Windows SMART tool for this controller?
Could CrystalDiskInfo? access SMART data?

comment:6 Changed 2 months ago by Csaba Kálmán

Yes, the number of connected ports is 6, and 2 unconnected.

I'm afraid, that we are not lucky with this controller. Even the official tools from HP are not providing all the information I would expect.
There is a Smart Storage Administrator (or the command line ssacli) utility, which cannot provide much more info just that:

Status:	OK
Exposed To OS:	No
Drive Configuration Type:	Data
Associated To Array:	Array B - 2 Logical Drive(s)
Size:	931.51 GiB (1000.20 GB)
Logical / Physical Block Size:	512 / 512 Bytes
Drive Type:	SATA SSD
Model:	ATA CT1000BX500SSD1
Serial Number:	2216E6294F64
Firmware Version:	M6CR054
Transfer Speed:	6 Gbps
SSD Wear Status:	Not Supported
WWID:	3001438032CAFCC0

Please note, that the Wear status is "Not supported".
That's why I hoped you super tool would help me out :)

Unfortunately, the CrystalDiskInfo? (8.17.7) cannot see ANY drive in my system.

comment:7 Changed 2 months ago by Christian Franke

Milestone: undecided
Resolution: wontfix
Status: newclosed

The above results suggest that this driver does not provide pass-through functionality.

Feel free to reopen this ticket if new information is available.

Note: See TracTickets for help on using tickets.