Opened 4 weeks ago

Closed 4 weeks ago

Last modified 4 weeks ago

#1646 closed defect (duplicate)

segmentation fault under linux ia64

Reported by: Anatoly Pugachev Owned by:
Priority: minor Milestone:
Component: smartctl Version: 7.3
Keywords: linux ia64 Cc:

Description

Hello!

Using debian sid (unstable) on my ia64 blade with hpsa (cciss) driver.

Running 'smartctl' for disk status, fails with segmentation fault:

# uname -a
Linux lifshitz 5.17.0-1-mckinley #1 SMP Debian 5.17.3-1 (2022-04-18) ia64 GNU/Linux
# ./smartctl -i /dev/sda -d cciss,0
smartctl 7.3 2022-02-28 r5338 [ia64-linux-5.17.0-1-mckinley] (local build)
Copyright (C) 2002-22, Bruce Allen, Christian Franke, www.smartmontools.org

Segmentation fault (core dumped)

running under gdb (for stack trace):

smartmontools-7.3# gdb -q -c core ./smartctl
Reading symbols from ./smartctl...
[New LWP 1588376]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/ia64-linux-gnu/libthread_db.so.1".
Failed to read a valid object file image from memory.
Core was generated by `./smartctl -i /dev/sda -d cciss,0'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  tunnelled_device<ata_device, scsi_device>::get_tunnel_dev (this=0xc00000000004d2b8) at scsiata.cpp:499
499       if (!scsidev->scsi_pass_through(iop)) {
(gdb) bt
#0  tunnelled_device<ata_device, scsi_device>::get_tunnel_dev (this=0xc00000000004d2b8) at scsiata.cpp:499
#1  sat::sat_device::scsi_pass_through (this=0xc00000000004d2b8, iop=0x60000fffffe1edd0) at scsiata.cpp:498
#2  0x4000000000092000 in virtual thunk to sat::sat_device::scsi_pass_through(scsi_cmnd_io*) () at scsiata.cpp:1315
#3  0x4000000000083290 in scsi_pass_through_yield_sense (device=0x600000000003b1f8, iop=0x60000fffffe1edd0, sinfo=...) at scsicmds.cpp:1221
#4  0x4000000000084b90 in scsiInquiryVpd (device=0x600000000003b1f8, vpd_page=0, pBuf=0x60000fffffe1ee50 "", bufLen=252) at scsicmds.cpp:911
#5  0x4000000000084f40 in supported_vpd_pages::supported_vpd_pages (this=0x600000000003b270, device=0x600000000003b1f8) at scsicmds.cpp:54
#6  0x40000000000bd010 in scsiPrintMain (device=0x600000000003b1f8, options=...) at scsiprint.cpp:3214
#7  0x4000000000011740 in main_worker (argc=5, argv=0x60000fffffe23698) at smartctl.cpp:1655
#8  0x4000000000005d70 in main (argc=5, argv=0x60000fffffe23698) at smartctl.cpp:1676

any ideas how to fix this? Thanks.

Change History (4)

comment:1 Changed 4 weeks ago by Christian Franke

Milestone: undecided

May be similar to GH issue 61.

The root of the problem is likely specific to ia64 architecture and may be outside the scope of smartctl (compiler bug, kernel bug). Needs to be investigated by a volunteer developer with access to such hardware.

comment:2 Changed 4 weeks ago by Anatoly Pugachev

ahh yes, it was me reporting on github, i just can't remember where i previously reported this issue. thanks for linking.

Sorry for creating a duplicate issue/ticket.

Last edited 4 weeks ago by Anatoly Pugachev (previous) (diff)

comment:3 Changed 4 weeks ago by Anatoly Pugachev

Resolution: duplicate
Status: newclosed

comment:4 Changed 4 weeks ago by Christian Franke

Milestone: undecided
Note: See TracTickets for help on using tickets.