Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#159 closed enhancement (fixed)

Support for Verbatim Pocket Hard Drive (4KiB LLS)

Reported by: astf Owned by: chrfranke
Priority: minor Milestone: Release 5.41
Component: drivedb Version: 5.40
Keywords: Cc:

Description

Using "-d usbjmicron" the device (USB ID 0x18a5:0x0227) works so far, but there are three small problems:

  1. The reported capacity is too low (it is a 250 GB drive):
    User Capacity:    137.438.952.960 bytes
    
  1. A warning is printed:
    255 Unknown_Attribute       0x000a   252   252   ---    Old_age   Always       -       0
    255 Unknown_Attribute       <== Data Page      |  WARNING: PREVIOUS ATTRIBUTE HAS TWO
    254 Free_Fall_Sensor        <== Threshold Page |  INCONSISTENT IDENTITIES IN THE DATA
    
  1. The device works with "-d usbjmicron,x" too, but then an error is reported:
    General Purpose Logging (GPL) feature set supported
    ATA_READ_LOG_EXT (addr=0x00:0x00, page=0, n=1) failed: scsi error medium or hardware error (serious)
    Read GP Log Directory failed.
    

I already added the device to wiki:Supported_USB-Devices.

Attachments (1)

log (9.1 KB) - added by astf 7 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 in reply to: ↑ description Changed 7 years ago by chrfranke

  • Milestone set to Release 5.41
  1. The reported capacity is too low (it is a 250 GB drive):

User Capacity: 137.438.952.960 bytes

Interesting...
1024B LLS (Long Logical Sectors)?
DCO (Device Configuration Overlay) active?
HPA (Host Protected Area) active?

Please provide output of "smartctl -d usbjmicron -r ataioctl,2 -q noserial -i /dev/ice" for further diagnostics (as attachment).

  1. A warning is printed:

...
255 Unknown_Attribute <== Data Page | WARNING: PREVIOUS ATTRIBUTE HAS TWO
254 Free_Fall_Sensor <== Threshold Page | INCONSISTENT IDENTITIES IN THE DATA

This should be fixed since r3132.

  1. The device works with "-d usbjmicron,x" too, but then an error is reported:

Apparently 48-bit ATA commands do not work and ",x" should not be used.

Changed 7 years ago by astf

comment:2 Changed 7 years ago by chrfranke

112-127: 3f 00 10 fc fb 00 00 00 ff ff ff 0f 00 00 07 00 |?...............|
                    word 60-61...^^ ^^ ^^ ^^
...
192-207: 00 00 00 00 00 00 00 00 2e 8b a3 03 00 00 00 00 |................|
                  word 100-103...^^ ^^ ^^ ^^ ^^ ^^ ^^ ^^

This drive apparently returns bogus information in word 100-103 ("Total Number of User Addressable Logical Sectors for 48-bit commands"). Legacy info in word 60-61 is set to max 28-bit value which is OK:

word 60-61   =    0xfffffff = 268,435,455 sectors = 137,438,952,960 bytes
word 100-103 = 0x0003a38b2e =  61,049,646 sectors =  31,257,418,752 bytes

smartctl prints the larger value in this case.

Possibly disk firmware bug hidden behind SCSI->ATA translation in USB bridge.

comment:3 Changed 7 years ago by astf

61,049,646 sectors = 31,257,418,752 bytes

These values actually make sense, if you assume 4096 bytes per sector instead of 512 bytes. This sector size is confirmed by this Samsung document (page 30).

comment:4 Changed 7 years ago by chrfranke

  • Owner changed from somebody to chrfranke
  • Status changed from new to accepted
  • Summary changed from Support for Verbatim Pocket Hard Drive to Support for Verbatim Pocket Hard Drive (4KiB LLS)

"Sector Size 4K" in the specs typically means 4KiB physical sectors (LPS) but 512B logical sectors.

But this drive actually reports 4KiB physical and logical sectors in words 106 and 117-118. Interestingly it also reports a false LBA28 size and ATA support for only ATA-6 revision 1 (2000). ATA-6 defined words 104-126 as "Reserved". LLS was added later in ATA-7 revision 3a (2003).

Thanks for this very first testcase for LLS. I will fix reported capacity soon.

comment:5 Changed 7 years ago by chrfranke

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:6 Changed 7 years ago by chrfranke

Please test current SVN if possible. Should work now without "-d usbjmicron".

comment:7 Changed 7 years ago by astf

works :)

smartctl 5.41 2011-04-05 r3310 [x86_64-unknown-linux-gnu-2.6.37-ARCH] (local build)
Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF INFORMATION SECTION ===
Model Family:     SAMSUNG SpinPoint N3U-3 (USB, 4KiB LLS)
...
User Capacity:    250.059.350.016 bytes [250 GB]
Sector Size:      4096 bytes logical/physical
Note: See TracTickets for help on using tickets.