Opened 8 years ago

Closed 8 years ago

#152 closed defect (worksforme)

Sometimes smartd does not complaints about errors by email

Reported by: art9 Owned by: somebody
Priority: major Milestone:
Component: smartd Version:
Keywords: needinfo Cc:

Description

Smartd does not complaint about errors by email sometimes by unknown reason.

For example this incident did not trigger notification:

Feb 24 20:32:25 mx14 smartd[19581]: Device: /dev/sg0 [megaraid_disk_51] [SAT], 4 Currently unreadable (pending) sectors (changed +1)
Feb 24 20:32:25 mx14 smartd[19581]: Device: /dev/sg0 [megaraid_disk_51] [SAT], previous self-test completed with error (read test element)
Feb 24 20:32:26 mx14 smartd[19581]: Device: /dev/sg0 [megaraid_disk_51] [SAT], Self-Test Log error count increased from 2 to 3

typical configuration:

/dev/sg0 -d sat+megaraid,50 -a -s L/../../7/00 -m postmaster
/dev/sg0 -d sat+megaraid,51 -a -s L/../../7/00 -m postmaster
/dev/sg0 -d sat+megaraid,52 -a -s L/../../7/00 -m postmaster

SVN rev 3267M

Change History (6)

comment:1 in reply to:  description Changed 8 years ago by Christian Franke

Component: allsmartd

..., previous self-test completed with error (read test element)

This does not send a mail because the error should also appear in the self-test log.

SVN rev 3267M

....M = locally modified. Any related changes?

If -s, --savestates is used this is likely a duplicate of ticket #35.

comment:2 Changed 8 years ago by Christian Franke

Keywords: needinfo added

Please check whether -s, --savestates option is used or enabled by default. If yes add -M daily directive (which is the default since r3278).

comment:3 Changed 8 years ago by art9

smartd does not run with -s option. Is that what you mean? M - just smartd.conf changes as I see.

ps. usually it sends notifications, but sometimes does not

comment:4 Changed 8 years ago by Christian Franke

Does the problem persist if smartd is restarted? Note that each warning message type is only send once per smartd run if no -M directive is specified.

comment:5 Changed 8 years ago by Christian Franke

Related: ticket #167.

comment:6 Changed 8 years ago by Christian Franke

Resolution: worksforme
Status: newclosed

Could not be reproduced except in the cases covered by ticket #167.

Note: See TracTickets for help on using tickets.