Opened 3 years ago

Closed 3 years ago

Last modified 4 months ago

#1460 closed patch (fixed)

Add to drivedb: WDC WUH72181xALE6Lz

Reported by: joel.neppel Owned by: Christian Franke
Priority: minor Milestone: Release 7.3
Component: drivedb Version:
Keywords: hdd Cc: joel.neppel@…

Description

Hello,
I am Joel, an intern at Western Digital, and I am looking to get a drive added to your database. I have attached the smartctl -x log for another Ultrastar DC HC550.

I also have an entry for you,

{ "Western Digital Ultrastar DC HC550",
  "WDC  ?WUH72181[68]ALE6L[14]",
  "", "",
  "-v 22,raw48,Helium_Level"
},

Here is a link to the data sheet: https://documents.westerndigital.com/content/dam/doc-library/en_us/assets/public/western-digital/product/data-center-drives/ultrastar-dc-hc500-series/data-sheet-ultrastar-dc-hc550.pdf

Let me know if you have any questions, thank you.

Attachments (4)

smartctl-WDC-WUH72181xALE6Lz.txt (11.5 KB ) - added by joel.neppel 3 years ago.
smartctl-WDC-WUH721818ALE6L4.txt (17.2 KB ) - added by joel.neppel 3 years ago.
0001-drivedb.h-Ultrastar-DC-HC550.patch (1.1 KB ) - added by shin 3 years ago.
Patch suggested
smartctl-WDC-WUH721818ALE6L4_2 (12.8 KB ) - added by shin 3 years ago.
smartctl log of a drive without prefix in the device model

Download all attachments as: .zip

Change History (13)

by joel.neppel, 3 years ago

comment:1 by Christian Franke, 3 years ago

Milestone: undecided

Same issue as in #1459:

Device Model:     XXXXX (internal Ultrastar DC HC550)

This is useless as a test case.

by joel.neppel, 3 years ago

comment:2 by joel.neppel, 3 years ago

I found a drive that has the correct model number. Regarding the spaces, I do not believe they have any meaning about the drive, it is just how the device model is reported.

in reply to:  2 ; comment:3 by TheDragonFire961, 3 years ago

Replying to Joel Neppel:

I found a drive that has the correct model number. Regarding the spaces, I do not believe they have any meaning about the drive, it is just how the device model is reported.

But are final versions to have the space, but is it only an internal thing?

Version 0, edited 3 years ago by TheDragonFire961 (next)

in reply to:  3 comment:4 by joel.neppel, 3 years ago

Replying to TheDragonFire961:

Replying to Joel Neppel:

I found a drive that has the correct model number. Regarding the spaces, I do not believe they have any meaning about the drive, it is just how the device model is reported.

But are final versions to have the space, or is it only an internal thing?

The ones being sold include the spaces.

comment:5 by Christian Franke, 3 years ago

Milestone: undecidedRelease 7.3

by shin, 3 years ago

Patch suggested

by shin, 3 years ago

smartctl log of a drive without prefix in the device model

comment:6 by shin, 3 years ago

Hello,

I'm Shin'ichiro Kawasaki at WDC. Recently, I made same request to smartmontool-database mailing list, without knowing this ticket.

https://listi.jpberlin.de/pipermail/smartmontools-database/2021-August/000661.html

Sorry about this duplicated request. I also appreciate the support of this model in drivedb.h.

I have attached a patch I suggest to support this model. It adds the entry as follows:

  { "Western Digital Ultrastar DC HC550",
    "(WDC  ?)?WUH72181[68]ALE6L[14]",
    "", "",
    // The product spec describes the attribute ID 22 as "Internal Environmental
    // status", but for historical reason, keep the description "Helium_Level".
    "-v 22,raw48,Helium_Level"
  },

One point to note about the patch is that the modelexp supports the model numbers both with and without "WDC" prefix. Some of the drives do not have the prefix. I also attached smartctl log of a drive without the prefix.

The other point is the inline comment about the SMART ID 22. The specification (link below) page 303 describes the SMART attribute as "Internal Environment status".

https://documents.westerndigital.com/content/dam/doc-library/en_us/assets/public/western-digital/product/data-center-drives/ultrastar-dc-hc500-series/product-manual-ultrastar-dc-hc550-sata-oem-spec.pdf

Many entries in drivedb.h describe it as "Helium_Level". For consistency, I think the new entry for this model should have the description "Helium_Level". But I wish to have the comment to note that it is different from the specification.

Thanks in advance for comments and actions.

comment:7 by Christian Franke, 3 years ago

Owner: set to Christian Franke
Status: newaccepted
Type: enhancementpatch

comment:8 by Christian Franke, 3 years ago

Resolution: fixed
Status: acceptedclosed

comment:9 by Christian Franke, 4 months ago

Ticket #1500 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.