Opened 9 years ago

Closed 8 years ago

Last modified 6 years ago

#140 closed defect (wontfix)

INQUIRY failed on LSI MegaRaid adapter

Reported by: sparkyodom2005 Owned by: somebody
Priority: major Milestone:
Component: all Version: 5.40
Keywords: megaraid linux Cc:

Description

lspci | grep RAID
08:00.0 RAID bus controller: LSI Logic / Symbios Logic MegaRAID SAS 1078 (rev 04)

smartctl -V

smartctl 5.40 2010-10-16 r3189 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

smartctl comes with ABSOLUTELY NO WARRANTY. This is free
software, and you are welcome to redistribute it under
the terms of the GNU General Public License Version 2.
See http://www.gnu.org for further details.

smartmontools release 5.40 dated 2010-10-16 at 16:34:38 UTC
smartmontools SVN rev 3189 dated 2010-10-16 at 16:35:49
smartmontools build host: x86_64-unknown-linux-gnu
smartmontools build configured: 2010-12-30 18:16:48 UTC
smartctl compile dated Dec 30 2010 at 10:17:15
smartmontools configure arguments: [no arguments given]

smartctl -a -d megaraid,1 /dev/sda
smartctl 5.40 2010-10-16 r3189 [x86_64-unknown-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

Smartctl open device: /dev/sda [megaraid_disk_01] failed: INQUIRY failed

Change History (4)

comment:1 Changed 9 years ago by Christian Franke

Keywords: megaraid linux added

Recent megaraid drivers may require sg or bsd devices to access physical drives. Please use lsscsi -g to detect appropriate /dev/sgX device. See ticket #46 for further info.

comment:2 Changed 8 years ago by Alex Samorukov

Resolution: wontfix
Status: newclosed

No feedback for > 10 months, closing bug.

comment:3 Changed 7 years ago by jonbendtsen

this page showed up in my own search for a solution, so I have decided to leave a note for any future users about what worked for me.

chrfranke's suggested solution, option 'lsscsi -g' did not work for me because I get no sg devices.

But if I change the smartctl type to '-d sat+megaraid,2' I do get S.M.A.R.T information with this command: smartctl -i -d sat+megaraid,2 /dev/sda

If I let the ,2 run through a sequence like from 2-14 I do get individual information about all my 12 disks. The Serial Number is different depending on which ,# I ask about.

However, if I keep the ,# static, like ,2 then it does not make any difference if I ask /dev/sda, /dev/sdb, ..., /dev/sdl or /dev/bsg/* I still get the same disk information sole dependent on the ,# part.

This means I can not use smartctl to correlate which disk is sda, sdb, ..., sdl. But it is possible to use "megacli -LdPdInfo?? -a0" because one of that commands output lines are "Virtual Drive: 11 (Target Id: 11)" which matches the lsscsi output "[0:2:11:0] disk SMC SMC2108 2.12 /dev/sdl". Another megacli output line is "Device Id: 14" which corresponds to the ,14 number above. The serial number from smartctl ..blabla... ,14 matches with the serial number from both "megacli -LdPdInfo?? -a0" and "megacli -pdInfo -PhysDrv??[$encdeviceid:$slotnr] -a$controllernr".

comment:4 Changed 6 years ago by k2chris1983

Adding more to jonbendtsen comment.

You will need to do the following:

MegaCli -LdPdInfo -a0 - This shows the "Device ID: XXX"

Run the command and note down the Device ID's.

Once you have all the Device ID's you can finally run your smartctl.

smartctl -S on -a -d megaraid,XXX /dev/sdN

Note: XXX = Device ID Number while N is the corresponding to mount.

Note: See TracTickets for help on using tickets.