Opened 2 months ago

Closed 2 months ago

#1330 closed defect (duplicate)

Device not yet supported: SEAGATE Expansion Desktop, 6.0TB (STEB6000403)

Reported by: gddsijh49usd Owned by:
Priority: minor Milestone:
Component: all Version:
Keywords: uas linux Cc:

Description (last modified by Christian Franke)

USB-Bridge ( 0x0bc2:0x331a ) is not yet listed here:
http://www.linux-usb.org/usb.ids

Any chances to monitor this device with smartmontools?


Trying to include a SEAGATE Expansion Desktop, 6.0TB (STEB6000403) Drive gives the following output:

smartctl --all  /dev/sda
smartctl 6.6 2016-05-31 r4324 [armv7l-linux-4.14.176-174] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

/dev/sda: Unknown USB bridge [0x0bc2:0x331a (0x915)]
Please specify device type with the -d option.

----------------------------------------------

smartctl --all -d sat /dev/sda
smartctl 6.6 2016-05-31 r4324 [armv7l-linux-4.14.176-174] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

Read Device Identity failed: scsi error unsupported field in scsi command

A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.

----------------------------------------------

smartctl --all -d scsi /dev/sda
smartctl 6.6 2016-05-31 r4324 [armv7l-linux-4.14.176-174] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Vendor:               Seagate
Product:              Expansion Desk
Revision:             0915
Compliance:           SPC-4
User Capacity:        6,001,175,125,504 bytes [6.00 TB]
Logical block size:   512 bytes
Physical block size:  4096 bytes
LU is fully provisioned
Logical Unit id:      0x3e4141415a46314e
Serial number:        NAAAXXXX
Device type:          disk
Local Time is:        Sat May  9 16:25:42 2020 CEST
SMART support is:     Unavailable - device lacks SMART capability.

=== START OF READ SMART DATA SECTION ===
Current Drive Temperature:     0 C
Drive Trip Temperature:        0 C

Error Counter logging not supported

No self-tests have been logged

Best Regards,

Chris

Change History (4)

comment:1 Changed 2 months ago by Christian Franke

Description: modified (diff)

comment:2 Changed 2 months ago by Christian Franke

Keywords: uas linux added
Milestone: undecided

USB Vendor ID 0x0bc2 now defaults to -d sat, see r4685, r4692. Some few Seagate devices require -d sat,12.

smartctl --all -d sat /dev/sda
smartctl 6.6 2016-05-31 r4324 [armv7l-linux-4.14.176-174] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

Read Device Identity failed: scsi error unsupported field in scsi command

This is the typical behavior with Seagate devices if UAS mode is enabled on Linux. If this is the case on your system, this ticket is a duplicate of #971. See SAT with UAS under Linux page for details.

comment:3 Changed 2 months ago by gddsijh49usd

Great, that was it ;-)

Disabling UAS made smartctl work perfectly.

With UAS enabled, neither "-T permissive" nor "-d sat,12" helped:

smartctl -d sat -T permissive -a /dev/sda
smartctl 6.6 2016-05-31 r4324 [armv7l-linux-4.14.176-174] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

Read Device Identity failed: scsi error unsupported field in scsi command

=== START OF INFORMATION SECTION ===
Device Model:     [No Information Found]
Serial Number:    [No Information Found]
Firmware Version: [No Information Found]
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   [No Information Found]
Local Time is:    Sun May 10 17:28:12 2020 CEST
SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 82-83 don't show if SMART supported.
SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 85-87 don't show if SMART is enabled.
A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.

--------------------------------------------------------------

smartctl -d sat,12 -T permissive -a /dev/sda
smartctl 6.6 2016-05-31 r4324 [armv7l-linux-4.14.176-174] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

Read Device Identity failed: scsi error unsupported field in scsi command

=== START OF INFORMATION SECTION ===
Device Model:     [No Information Found]
Serial Number:    [No Information Found]
Firmware Version: [No Information Found]
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   [No Information Found]
Local Time is:    Sun May 10 17:28:43 2020 CEST
SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 82-83 don't show if SMART supported.
SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 85-87 don't show if SMART is enabled.
A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.

-----------------------------------------------------

without UAS:
echo "0x0bc2:0x331a:u" > /sys/module/usb_storage/parameters/quirks

--> 
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/2p, 5000M
        |__ Port 1: Dev 4, If 0, Class=Mass Storage, Driver=usb-storage, 5000M

smartctl -d sat  -a /dev/sda
smartctl 6.6 2016-05-31 r4324 [armv7l-linux-4.14.176-174] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Device Model:     ST6000DM003-2CY186
Serial Number:    WCT31G3B
LU WWN Device Id: 5 000c50 0cd3e50b1
Firmware Version: 0001
User Capacity:    6,001,175,126,016 bytes [6.00 TB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    5425 rpm
Form Factor:      3.5 inches
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   ACS-3 T13/2161-D revision 5
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Sun May 10 17:50:53 2020 CEST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled
Last edited 2 months ago by Christian Franke (previous) (diff)

comment:4 Changed 2 months ago by Christian Franke

Milestone: undecided
Resolution: duplicate
Status: newclosed
Type: enhancementdefect

Same Linux UAS related issue as in tickets #971, #1069, #1078, #1092 and #1312.

USB Id is already mapped to -d sat by drive database.

Note: See TracTickets for help on using tickets.