#1242 closed enhancement (invalid)

Only one NVMe device is examined under Windows (Intel VMD NVMe RAID)

Reported by: edo1 Owned by:
Priority: minor Milestone:
Component: all Version: 7.0
Keywords: nvme windows Cc:

Description

I have two NVMe devices installed.

detection (as admin):

PS C:\Windows\system32> smartctl.exe --scan
/dev/sda -d ata # /dev/sda, ATA device
/dev/sdb -d ata # /dev/sdb, ATA device
/dev/nvme0 -d nvme # /dev/nvme0, NVMe device

detection (as regular user):

PS C:\Users\edo> smartctl.exe --scan
/dev/sda -d scsi # /dev/sda, SCSI device
/dev/sdb -d scsi # /dev/sdb, SCSI device

smartctl -x -d nvme /dev/nvme0 works as expected.

I haven't managed to get SMART status of the second NVMe device

PS C:\Windows\system32> smartctl.exe -x -d nvme /dev/nvme1
smartctl 7.0 2018-12-30 r4883 [x86_64-w64-mingw32-2012r2] (sf-7.0-1)
Copyright (C) 2002-18, Bruce Allen, Christian Franke, www.smartmontools.org

Smartctl open device: /dev/nvme1 failed: No such file or directory
PS C:\Windows\system32> smartctl.exe -x -d ata /dev/sda
smartctl 7.0 2018-12-30 r4883 [x86_64-w64-mingw32-2012r2] (sf-7.0-1)
Copyright (C) 2002-18, Bruce Allen, Christian Franke, www.smartmontools.org

Read Device Identity failed: Input/output error

A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.
PS C:\Windows\system32> smartctl.exe -x -d scsi /dev/sda
smartctl 7.0 2018-12-30 r4883 [x86_64-w64-mingw32-2012r2] (sf-7.0-1)
Copyright (C) 2002-18, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Vendor:               NVMe
Product:              INTEL SSDPE2KX04
Revision:             0131
Compliance:           SPC-4
User Capacity:        4 000 787 030 016 bytes [4,00 TB]
Logical block size:   512 bytes
LU is fully provisioned
Rotation Rate:        Solid State Device
Logical Unit id:      eui.0001903184E4D25C♥
Serial number:        PHLJ823608MG4P0DGN
Device type:          disk
Local Time is:        Sun Sep 29 20:07:50 2019 RTZ
SMART support is:     Unavailable - device lacks SMART capability.
Read Cache is:        Enabled
Writeback Cache is:   Disabled

=== START OF READ SMART DATA SECTION ===

Current Drive Temperature:     26 C
Drive Trip Temperature:        87 C

Error Counter logging not supported


[GLTSD (Global Logging Target Save Disable) set. Enable Save with '-S on']
Device does not support Self Test logging
Device does not support Background scan results logging
PS C:\Windows\system32> smartctl.exe -x -d scsi /dev/sdb
smartctl 7.0 2018-12-30 r4883 [x86_64-w64-mingw32-2012r2] (sf-7.0-1)
Copyright (C) 2002-18, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Vendor:               NVMe
Product:              INTEL SSDPE2KX02
Revision:             0120
Compliance:           SPC-4
User Capacity:        2 000 398 934 016 bytes [2,00 TB]
Logical block size:   512 bytes
LU is fully provisioned
Rotation Rate:        Solid State Device
Logical Unit id:      eui.000157257EE4D25C♥
Serial number:        BTLJ815308K02P0BGN
Device type:          disk
Local Time is:        Sun Sep 29 20:07:57 2019 RTZ
SMART support is:     Unavailable - device lacks SMART capability.
Read Cache is:        Enabled
Writeback Cache is:   Disabled

=== START OF READ SMART DATA SECTION ===

Current Drive Temperature:     28 C
Drive Trip Temperature:        87 C

Error Counter logging not supported


[GLTSD (Global Logging Target Save Disable) set. Enable Save with '-S on']
Device does not support Self Test logging
Device does not support Background scan results logging

Windows version:

PS C:\Windows\system32> [Environment]::OSVersion

                                         Platform ServicePack                                       Version                                           VersionString
                                         -------- -----------                                       -------                                           -------------
                                          Win32NT                                                   6.3.9600.0                                        Microsoft Windows NT 6.3.9600.0


PS C:\Windows\system32> (Get-WmiObject -class Win32_OperatingSystem).Caption
Microsoft Windows Server 2012 R2 Standard

Attachments (3)

intel.png (4.2 KB) - added by edo1 12 months ago.
vroc.png (10.0 KB) - added by edo1 12 months ago.
smartctl.txt (5.6 KB) - added by edo1 12 months ago.

Download all attachments as: .zip

Change History (12)

Changed 12 months ago by edo1

Attachment: intel.png added

comment:1 Changed 12 months ago by edo1

Component: allsmartctl
Version: 7.0

comment:2 Changed 12 months ago by Christian Franke

Component: smartctlall
Keywords: nvme windows added
Milestone: undecided

Which NVMe driver is used?
Are other non-NVMe drives connected to the system?

Please provide output of smartctl -r ioctl,2 --scan as an attachment to this ticket.

comment:3 Changed 12 months ago by edo1

Which NVMe driver is used?

How to check it?

Are other non-NVMe drives connected to the system?

No other drives

Please provide output of smartctl -r ioctl,2 --scan

PS C:\Windows\system32> smartctl -r ioctl,2 --scan
# scan_smart_devices: DEVICESCAN with pattern not implemented yet
PS C:\Windows\system32> smartctl --version
smartctl 7.0 2018-12-30 r4883 [x86_64-w64-mingw32-2012r2] (sf-7.0-1)
Copyright (C) 2002-18, Bruce Allen, Christian Franke, www.smartmontools.org

smartctl comes with ABSOLUTELY NO WARRANTY. This is free
software, and you are welcome to redistribute it under
the terms of the GNU General Public License; either
version 2, or (at your option) any later version.
See http://www.gnu.org for further details.

smartmontools release 7.0 dated 2018-12-30 at 14:47:55 UTC
smartmontools SVN rev 4883 dated 2018-12-30 at 14:48:54
smartmontools build host: x86_64-w64-mingw32
smartmontools build with: C++14, GCC 7.3-win32 20180312
smartmontools configure arguments: 'build_alias=x86_64-pc-linux-gnu' 'host_alias=x86_64-w64-mingw32'

comment:4 in reply to:  3 Changed 12 months ago by Christian Franke

Which NVMe driver is used?

How to check it?

Start device manager -> select controller -> show properties -> select driver tab -> push driver details button. This should show filenames, manufacturer and version.

Unfortunately Intel NVMe and Intel RST drivers implement NVMe pass-through differently (see also NVMe wiki page).

Please provide output of smartctl -r ioctl,2 --scan

PS C:\Windows\system32> smartctl -r ioctl,2 --scan
# scan_smart_devices: DEVICESCAN with pattern not implemented yet

Could not reproduce. This error message only occurs if there are extra parameters behind --scan. Please retry from cmd.exe.

Changed 12 months ago by edo1

Attachment: vroc.png added

Changed 12 months ago by edo1

Attachment: smartctl.txt added

comment:5 Changed 12 months ago by edo1

Start device manager -> select controller -> show properties -> select driver tab -> push driver details button. This should show filenames, manufacturer and version.

screenshot attached

Please retry from cmd.exe

It works such way, output attached

comment:6 Changed 12 months ago by Christian Franke

...
 \\.\Scsi0:: successfully opened
  IOCTL_SCSI_MINIPORT(CC_CSMI_1) failed, Error=1117
 \\.\Scsi1:: successfully opened
  IOCTL_SCSI_MINIPORT(CC_CSMI_1) succeeded, bytes returned: 204
CSMI_SAS_DRIVER_INFO:
  Name:        "iaStorE"
  Description: "Intel Virtual RAID on CPU"
  Revision:    6.1
  IOCTL_SCSI_MINIPORT(CC_CSMI_20) succeeded, bytes returned: 2080
CSMI_SAS_PHY_INFO: NumberOfPhys=6
...
 \\.\Scsi2:: successfully opened
...
  IOCTL_SCSI_MINIPORT(CC_CSMI_20) succeeded, bytes returned: 2080
CSMI_SAS_PHY_INFO: NumberOfPhys=8
...
  \\.\Scsi0:: successfully opened
  [nvme probe succeeded]
  \\.\Scsi1:: successfully opened
  nvme probe failed: NVME_PASS_THROUGH failed, Error=1117
  \\.\Scsi2:: successfully opened
  nvme probe failed: NVME_PASS_THROUGH failed, Error=1117
  \\.\Scsi3:: Open failed, Error=2
...
  \\.\Scsi31:: Open failed, Error=2
/dev/sda -d ata # /dev/sda, ATA device
/dev/sdb -d ata # /dev/sdb, ATA device
/dev/nvme0 -d nvme # /dev/nvme0, NVMe device

Only \\.\Scsi0: supports NVME_PASS_THROUGH. \\.\Scsi[12]: support CSMI with 6 or 8 ports which are all reported as empty. Other \\.\ScsiN: nodes do not exist.

The added RAID capability possibly breaks the full NVMe pass-through functionality of this driver. If this driver provides an alternative NVMe pass-through I/O-control, documentation or sample source code is required.

If possible, please test whether CrystalDiskInfo could access both devices.

comment:7 Changed 12 months ago by Christian Franke

Summary: Only one NVMe device is examined under WindowsOnly one NVMe device is examined under Windows (Intel VMD NVMe RAID)
Type: defectenhancement

comment:8 Changed 11 months ago by edo1

CrystalDiskInfo? cannot access SMART data for second drive as well.

comment:9 Changed 10 months ago by Christian Franke

Milestone: undecided
Resolution: invalid
Status: newclosed

Test results suggest that this is limitation/bug of the Intel VMD NVMe RAID driver. Cannot be fixed by smartmontools.

Note: See TracTickets for help on using tickets.