Opened 2 months ago

Closed 3 weeks ago

#1233 closed defect (invalid)

smartctl exit code 4. "scsiPrintFormatStatus: Failed" in -a output

Reported by: padner Owned by:
Priority: minor Milestone:
Component: smartctl Version: 7.0
Keywords: scsi Cc:

Description

After upgrade smartmontools from 6.6-1.el7 to 7.0-1.el7, smartctl exit with code 4.

This line is present in the output: scsiPrintFormatStatus: Failed [Input/output error]

smartctl -a /dev/bus/0 -d megaraid,44
smartctl 7.0 2018-12-30 r4883 [x86_64-linux-4.14.35-1818.1.6.el7uek.x86_64] (local build)
Copyright (C) 2002-18, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Vendor:               HGST
Product:              HUH721212AL5204
Revision:             C3D0
Compliance:           SPC-4
User Capacity:        12,000,138,625,024 bytes [12.0 TB]
Logical block size:   512 bytes
Physical block size:  4096 bytes
LU is fully provisioned
Rotation Rate:        7200 rpm
Form Factor:          3.5 inches
Logical Unit id:      0x5000cca253084a6c
Serial number:        8DG4KATZ
Device type:          disk
Transport protocol:   SAS (SPL-3)
Local Time is:        Fri Sep  6 11:27:00 2019 VLAT
SMART support is:     Available - device has SMART capability.
SMART support is:     Enabled
Temperature Warning:  Enabled

=== START OF READ SMART DATA SECTION ===
SMART Health Status: OK

scsiPrintFormatStatus: Failed [Input/output error]
Current Drive Temperature:     25 C
Drive Trip Temperature:        85 C

Manufactured in week 43 of year 2017
Specified cycle count over device lifetime:  50000
Accumulated start-stop cycles:  159
Specified load-unload count over device lifetime:  600000
Accumulated load-unload cycles:  168
Vendor (Seagate Cache) information
  Blocks sent to initiator = 109731280584704

Error counter log:
           Errors Corrected by           Total   Correction     Gigabytes    Total
               ECC          rereads/    errors   algorithm      processed    uncorrected
           fast | delayed   rewrites  corrected  invocations   [10^9 bytes]  errors
read:          0        0         0         0     120567      14366.075           0
write:         0        0         0         0      14168       5367.122           0
verify:        0        0         0         0        396     612007.092           0

Non-medium error count:        0

No Self-tests have been logged

But with another drive of the same model, everything is fine. This text instead of an error string

Grown defects during certification <not available>
Total blocks reassigned during format <not available>
Total new blocks reassigned <not available>
Power on minutes since format <not available>

Attachments (4)

megaraid44 (3.8 KB) - added by padner 7 weeks ago.
megaraid45 (4.0 KB) - added by padner 7 weeks ago.
megaraid44_r4965.txt (3.8 KB) - added by padner 6 weeks ago.
megaraid45_r4965.txt (4.0 KB) - added by padner 6 weeks ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 2 months ago by padner

Summary: smartctl exit code 4smartctl exit code 4. "scsiPrintFormatStatus: Failed" in -a output

comment:2 Changed 2 months ago by Christian Franke

Keywords: scsi added
Milestone: unscheduledundecided

But with another drive of the same model, everything is fine.

Same Revision: C3D0 and Compliance: SPC-4?
Same controller used for device access?

PS: Please do not set the Milestone in future submissions.

comment:3 in reply to:  2 Changed 2 months ago by padner

Replying to Christian Franke:

But with another drive of the same model, everything is fine.

Same Revision: C3D0 and Compliance: SPC-4?
Same controller used for device access?

PS: Please do not set the Milestone in future submissions.

Yes, same revision, compliance and controller Intel RS25SB008

smartctl -a /dev/bus/0 -d megaraid,45
smartctl 7.0 2018-12-30 r4883 [x86_64-linux-4.14.35-1818.1.6.el7uek.x86_64] (local build)
Copyright (C) 2002-18, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Vendor:               HGST
Product:              HUH721212AL5204
Revision:             C3D0
Compliance:           SPC-4
User Capacity:        12,000,138,625,024 bytes [12.0 TB]
Logical block size:   512 bytes
Physical block size:  4096 bytes
LU is fully provisioned
Rotation Rate:        7200 rpm
Form Factor:          3.5 inches
Logical Unit id:      0x5000cca2530a8e40
Serial number:        8DG5TYVZ
Device type:          disk
Transport protocol:   SAS (SPL-3)
Local Time is:        Mon Sep  9 13:04:29 2019 VLAT
SMART support is:     Available - device has SMART capability.
SMART support is:     Enabled
Temperature Warning:  Enabled

=== START OF READ SMART DATA SECTION ===
SMART Health Status: OK

Grown defects during certification <not available>
Total blocks reassigned during format <not available>
Total new blocks reassigned <not available>
Power on minutes since format <not available>
Current Drive Temperature:     29 C
Drive Trip Temperature:        85 C

Manufactured in week 43 of year 2017
Specified cycle count over device lifetime:  50000
Accumulated start-stop cycles:  1
Specified load-unload count over device lifetime:  600000
Accumulated load-unload cycles:  310
Elements in grown defect list: 0

Vendor (Seagate Cache) information
  Blocks sent to initiator = 2358107820785664

Error counter log:
           Errors Corrected by           Total   Correction     Gigabytes    Total
               ECC          rereads/    errors   algorithm      processed    uncorrected
           fast | delayed   rewrites  corrected  invocations   [10^9 bytes]  errors
read:          0        0         0         0   16975260     705147.956           0
write:         0        0         0         0      71298      75781.560           0
verify:        0        0         0         0        514          0.135           0

Non-medium error count:        0

No Self-tests have been logged

Last edited 2 months ago by padner (previous) (diff)

comment:4 Changed 7 weeks ago by Christian Franke

Please provide outputs of smartctl -r ioctl,2 -a /dev/bus/0 -d megaraid,N for both devices as attachments to this ticket.

Changed 7 weeks ago by padner

Attachment: megaraid44 added

Changed 7 weeks ago by padner

Attachment: megaraid45 added

comment:5 Changed 7 weeks ago by padner

Thanks for the answer, Christian!

I added attachments

comment:6 Changed 6 weeks ago by Christian Franke

Changeset r4958 adds workarounds for bogus log directories from Samsung SAS SSDs (see tickets #1225 and #1239). It may also affect the output of these HGST SAS HDDs. Please test if possible. Tarballs with source and binaries are available at https://builds.smartmontools.org.

Changed 6 weeks ago by padner

Attachment: megaraid44_r4965.txt added

Changed 6 weeks ago by padner

Attachment: megaraid45_r4965.txt added

comment:7 Changed 6 weeks ago by padner

Thank. I tested version r4965, but there is an error, attached files

comment:8 Changed 5 weeks ago by Christian Franke

So recent commits did not change the result:

smartctl -d megaraid,44 ...: Exits with 4 because the following SCSI commands fail:
READ DEFECT DATA (12), and
LOG SENSE of FORMAT STATUS LOG PAGE (08h/00h).

smartctl -d megaraid,45 ...: Exits with 0 because all commands succeed.

The commands sent to both disks are identical. So this is likely not a bug in smartctl.

Are these disks possibly in different modes (RAID vs. Spare disk, Active vs. Standby power mode)?

comment:9 Changed 3 weeks ago by padner

Hi, Christian.

Yes, they have different modes.

44

Firmware state: Hotspare, Spun down
Inquiry Data: HGST    HUH721212AL5204 C3D08DG4KATZ 

45

Firmware state: Online, Spun Up
Inquiry Data: HGST    HUH721212AL5204 C3D08DG5TYVZ        

If disable controller feature "Spin Down of Hot Spares", drive firmware state change to "Online, Spun Up" and smartctl return 0

ps sorry for the long answer

comment:10 Changed 3 weeks ago by Christian Franke

Milestone: undecided
Resolution: invalid
Status: newclosed

SCSI commands failed because the disk was spun down. This is not a smartctl bug.

Note: See TracTickets for help on using tickets.