Opened 4 weeks ago

Closed 2 weeks ago

Last modified 2 weeks ago

#1132 closed defect (wontfix)

attrlog files contains attribute strings for SCSI disks, but attribute numbers for ATA disks

Reported by: Ulrich Owned by:
Priority: minor Milestone:
Component: smartd Version: 6.6
Keywords: Cc:

Description

While trying to evaluate the numbers smartd write to attrlog files, I noticed that for SCSI disks the attributes have names like "temperature", while for ATA disks there are no attribute names, i.e. the attribute is specified by number (like 194).
I'd prefer (ore or less) short and stable attribute names if known.

For example a line in an ATA attrlog looks like:
2015-12-18 12:10:28; 1;63;38776360; 3;98;0; 4;99;1185; 5;100;0; 7;84;290151632; 9;68;28632; 10;100;0; 12;99;1191; 194;41;55834574889; 195;63;38776360; 197;100;0; 198;100;0; 199;200;0; 200;100;0; 202;100;0;

A line from a SCSI attrlog looks like:
2016-03-08 15:05:07; read-corr-by-ecc-fast;0; read-corr-by-ecc-delayed;26075; read-corr-by-retry;0; read-total-err-corrected;26075; read-corr-algorithm-invocations;0; read-gb-processed;337052.962; read-total-unc-errors;0; write-corr-by-ecc-fast;0; write-corr-by-ecc-delayed;48719; write-corr-by-retry;0; write-total-err-corrected;48719; write-corr-algorithm-invocations;0; write-gb-processed;1481.749; write-total-unc-errors;0; verify-corr-by-ecc-fast;0; verify-corr-by-ecc-delayed;0; verify-corr-by-retry;0; verify-total-err-corrected;0; verify-corr-algorithm-invocations;0; verify-gb-processed;0.000; verify-total-unc-errors;0; non-medium-errors;366; temperature;28;

Change History (3)

comment:1 Changed 3 weeks ago by Christian Franke

Milestone: undecided

ATA SMART and SCSI DIAGNOSTICS (not called SMART) information differ considerably and so do smartctl output and smartd attribute logs.

ATA SMART Attributes are vendor specific. Known attribute names depend on drive database entries which may change over time. Therefore it has been decided (see r2870) to log the attribute IDs.

SCSI "Attributes" are not vendor specific, so the names are logged (see r3687).

comment:2 Changed 2 weeks ago by Christian Franke

Milestone: undecided
Resolution: wontfix
Status: newclosed

This is by design, see above comment for details.

Any change of format would break backward compatibility.

A possibly fix would be to add an command line option which selects an alternative log format. Feel free to reopen this ticket if you could provide a patch.

comment:3 Changed 2 weeks ago by Ulrich

Talking about backward compatibility: Is the format as it is now specified anywhere?

Note: See TracTickets for help on using tickets.