Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#1092 closed defect (duplicate)

Seagate Backup Plus Hub 8 TB

Reported by: hueldur Owned by:
Priority: minor Milestone:
Component: all Version: 6.6
Keywords: uas linux Cc:

Description

I am having trouble reading the SMART output of a Seagate Backup Plus Hub 8 TB on Debian Stretch. Without specifying a -d argument, smartctl fails saying
/dev/sdb: Unknown USB bridge [0x0bc2:0xab38 (0x100)]

The options -d usbcypress, -d usbjmicron, -d marvell, -d sat all fail without producing an output from the device. -d scsi is the only option producing any reasonable output:

…$ sudo smartctl -a -d scsi /dev/sdb
smartctl 6.6 2016-05-31 r4324 [x86_64-linux-4.9.0-8-amd64] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org
 
=== START OF INFORMATION SECTION ===
Vendor:               Seagate
Product:              Backup+ Hub BK
Revision:             D781
Compliance:           SPC-4
User Capacity:        8,001,563,221,504 bytes [8.00 TB]
Logical block size:   512 bytes
Physical block size:  4096 bytes
Logical Unit id:      0x5000000000000001
Serial number:        NA9Q53LY
Device type:          disk
Local Time is:        Fri Sep 21 19:41:00 2018 CEST
SMART support is:     Available - device has SMART capability.
SMART support is:     Disabled
Temperature Warning:  Disabled or Not Supported
 
=== START OF READ SMART DATA SECTION ===
SMART Health Status: OK
Current Drive Temperature:     0 C
Drive Trip Temperature:        0 C
 
Error Counter logging not supported
 
Device does not support Self Test logging


For now, I have added the drive under “Unsupported Devices” in the USB devices list. My question is if this can be considered normal behavior and the drive does indeed not support additional output or if the support from smartmontools is incomplete?

Change History (6)

comment:1 in reply to:  description ; Changed 8 months ago by Christian Franke

/dev/sdb: Unknown USB bridge [0x0bc2:0xab38 (0x100)]

Should be detected as -d sat since r4382, r4384 (ticket #786). USB Vendor ID 0x0bc2 now defaults to -d sat, see r4685, r4692. Please run update_smart_drivedb or download the drive database manually.

comment:2 Changed 8 months ago by Christian Franke

Keywords: uas linux added
Milestone: undecided

I am having trouble reading the SMART output of a Seagate Backup Plus Hub 8 TB on Debian Stretch.

Is UAS transfer mode enabled? If yes, the Linux kernel rejects SAT ATA pass-through to Seagate USB devices. See tickets #971, #1069, #1078 and the USB wiki page for details.

comment:3 in reply to:  1 Changed 8 months ago by hueldur

Replying to Christian Franke:

/dev/sdb: Unknown USB bridge [0x0bc2:0xab38 (0x100)]

Should be detected as -d sat since r4382, r4384 (ticket #786). USB Vendor ID 0x0bc2 now defaults to -d sat, see r4685, r4692. Please run update_smart_drivedb or download the drive database manually.

Thanks for the instructions on how to update the drive-db. My on my debian box, the update_smat_drivedb was not installed, so I had to download it manually (replace /var/lib/smartmontools/drivedb/drivedb.h with the new one from the drive database.

After the update, the Unknown USB bridge error disappeared, however, still no reasonable output. The following helped to fix that:

Replying to Christian Franke:

I am having trouble reading the SMART output of a Seagate Backup Plus Hub 8 TB on Debian Stretch.

Is UAS transfer mode enabled? If yes, the Linux kernel rejects SAT ATA pass-through to Seagate USB devices. See tickets #971, #1069, #1078 and the USB wiki page for details.

UAS transfer mode was enabled, and it seems like the rejection by the Linux kernel was the cause of the issues.
The referenced tickets (#971 and #1078 in particular) helped me to disable UAS and get what I believe to be reasonable SMART output. The main steps were: Adding the kernel boot parameter usb_storage.quirks=0x0bc2:0xab38:u as GRUB_CMDLINE_LINUX in /etc/default/grub, running update-grub and rebooting the system.

Thanks a lot, Christian, for your help, and for smartmontools!

Last edited 8 months ago by hueldur (previous) (diff)

comment:4 Changed 8 months ago by Christian Franke

Milestone: undecided
Resolution: duplicate
Status: newclosed

Same Linux UAS related issue as in tickets #971, #1069 and #1078.

comment:5 Changed 8 months ago by Christian Franke

Thanks for the feedback.

Does Linux fall back to much lower (USB 2.0?) speed if usb_storage.quirks=0x0bc2:0xab38:u is added? For speed check use for example:

# dd if=/dev/sdX iflag=direct of=/dev/null bs=1M count=1K

(O_DIRECT reads of 1GiB in 1MiB blocks)

comment:6 in reply to:  5 Changed 8 months ago by hueldur

Replying to Christian Franke:

Thanks for the feedback.

Does Linux fall back to much lower (USB 2.0?) speed if usb_storage.quirks=0x0bc2:0xab38:u is added? For speed check use for example:

# dd if=/dev/sdX iflag=direct of=/dev/null bs=1M count=1K

(O_DIRECT reads of 1GiB in 1MiB blocks)

I am currently running a burn-in test on the drive which will probably take the entire week to complete, so I can't run the dd test for now. Part of my burn-in test are badblocks write-tests. During read-and-compare phases I get a solid 170 MB/s as reported by iotop. The max. speed for this drive as stated by Seagate is 160 MB/s, so it doesn't look like performance is affected.

Note: See TracTickets for help on using tickets.