Opened 12 months ago

Closed 11 months ago

Last modified 8 months ago

#1071 closed patch (fixed)

patch for drivedb.h: Micron_5100_MTFDDAK3T8TCB

Reported by: Gabriele Pohl Owned by: Christian Franke
Priority: minor Milestone: Release 7.0
Component: drivedb Version:
Keywords: Cc:

Description

Anthony D'Atri wrote via database ML:

Here's a diff against smartmontools-code-r4761-trunk-smartmontools to address Micron issues.

Polarity of wear counter correction
Support new 5200 drives
Break out 5100/5200 into a separate stanza and enable additional attributes
Recognize drives with Dell's goofy OEM inquiry model string.
They have Micron diddle their drives
because the normal Micron_5100_MTFD string
breaks some ancient HBA of theirs

Internal error: unable to compile regular expression "Crucial_CT(128|256|512)MX100SSD1|Crucial_CT(200|250|256|500|512|1000|1024)MX200SSD[1346]|Crucial_CT(275|525|1050|2050)MX300SSD[14]|Crucial_CT(120|240|480|960)M500SSD[134]|Crucial_CT(128|256|512|1024)M550SSD[134]|Micron_M500_MTFDDA[KTV](120|240|480|960)MAV|(Micron_)?M510[_-]MTFDDA[KTV](128|256)MAZ|(Micron_)?M550[_-]MTFDDA[KTV](064|128|256|512|1T0)MAY|Micron_M600_(EE|MT)FDDA[KTV](128|256|512|1T0)MBF[25Z]?|Micron_M500DC_(EE|MT)FDDA[AK](120|240|480|800)MBB|Micron_1100_MTFDDA[KV](256|512|1T0|2T0)TBN|MICRON_M510DC_(EE|MT)FDDAK(120|240|480|800|960)MBP|": Empty '|' subexpression
Please inform smartmontools developers at smartmontools-support@listi.jpberlin.de

Attachments (3)

smartctl-Micron_5100_2018-08-22.txt (15.8 KB) - added by Gabriele Pohl 12 months ago.
smartctl reports
adatri-micron-2018-08-22.diff (2.9 KB) - added by Gabriele Pohl 12 months ago.
drivedb.h: diff against trunk version 4761
adatri-micron-2018-09-07.diff (3.5 KB) - added by Gabriele Pohl 12 months ago.
drivedb patch

Download all attachments as: .zip

Change History (10)

Changed 12 months ago by Gabriele Pohl

smartctl reports

Changed 12 months ago by Gabriele Pohl

drivedb.h: diff against trunk version 4761

comment:1 Changed 12 months ago by Christian Franke

Milestone: undecided
Summary: patch for drivedb.h: Internal error: unable to compile regular expressionpatch for drivedb.h: Micron_5100_MTFDDAK3T8TCB
Type: defectpatch

Thanks for the patch. Unfortunately it introduces a bug which results in an error message.

Please rework the patch as follows:

  • Fix regex reported in Internal error: ... message.
  • Comment out -v ... lines which are already handled by the DEFAULT entry.
  • Avoid excess long lines.

comment:2 Changed 12 months ago by Gabriele Pohl

Anthony D'Atri wrote on Fri, 7 Sep 2018 16:04:33 -0700:

I had not realized that the DEFAULT entry lines would be inherited

Here is an updated patch that should resolve the below errors.

Changed 12 months ago by Gabriele Pohl

drivedb patch

comment:3 Changed 12 months ago by Christian Franke

Milestone: undecidedRelease 6.7
Owner: set to Christian Franke
Status: newaccepted

Patch looks good so far.

PS: For future patches, please use unified diff format (e.g. diff -u).

comment:4 Changed 12 months ago by Christian Franke

Please also provide a smartctl -x output of a real world device (with patch attached to drivedb.h).

Note that smartctl -a only prints legacy SMART information. It does not include Log Directory, new SMART logs, Device Statistics, SATA Phy Event Counters, etc. .

comment:5 Changed 11 months ago by Christian Franke

Resolution: fixed
Status: acceptedclosed

Patch applied in r4769, r4771. Thanks.

Model family name and indentation aligned with other entries.

comment:6 Changed 11 months ago by Christian Franke

Ticket #1022 has been marked as a duplicate of this ticket.

comment:7 Changed 8 months ago by Christian Franke

Milestone: Release 6.7Release 7.0

Milestone renamed

Note: See TracTickets for help on using tickets.