Opened 8 months ago

Last modified 8 months ago

#1070 new defect

SSDSC2KB019T7R scsi error badly formed scsi parameters

Reported by: Mark Heily Owned by:
Priority: minor Milestone: undecided
Component: all Version: 6.2
Keywords: linux scsi Cc:

Description

Dell-branded Intel drive with model # SSDSC2KB019T7R is not in the database, and generates an error message in smartctl 6.2:

Read SMART Selective Self-test Log failed: scsi error badly formed scsi parameters

I compiled smartmontools from source and tried again, but got the same error.

See attached for the full output of "smartctl -r ioctl,2 -a /dev/sda"

Attachments (1)

smartctl6_2_with_ioctl.txt (35.1 KB) - added by Mark Heily 8 months ago.

Download all attachments as: .zip

Change History (3)

Changed 8 months ago by Mark Heily

Attachment: smartctl6_2_with_ioctl.txt added

comment:1 Changed 8 months ago by Christian Franke

Keywords: linux scsi added
Milestone: undecided

Please note that drive database and the SCSI error are unrelated. Adding the device to database won't fix the SCSI error.

Possibly related: tickets #819 and #826.

Please check kernel log for original ATA error code (see ticket #826).

comment:2 Changed 8 months ago by Christian Franke

Please also provide output of smartctl -r ioctl,2 -x /dev/sda to check whether 48-bit ATA commands (e.g. READ LOG EXT) work. Also include possible kernel messages which report the original ATA error and status code: ...translated ATA stat/err 0x../.. to SCSI SK/ASC/ASCQ 0x5/21/04.

Note: See TracTickets for help on using tickets.