Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#1069 closed defect (duplicate)

Maxtor M3 Portable 4TB

Reported by: smartjerome Owned by:
Priority: minor Milestone:
Component: all Version: 6.6
Keywords: uas linux Cc:

Description

Hi.

According to https://www.smartmontools.org/ticket/875 and https://www.smartmontools.org/wiki/Supported_USB-Devices, the Maxtor M3 Portable 4TB should work using -d sat.

With mine, it doesn't. I get more info when using scsi.

# lsusb
Bus 001 Device 012: ID 0bc2:61b7 Seagate RSS LLC

# smartctl --all -d sat  /dev/sdd
[...]
Read Device Identity failed: scsi error unsupported field in scsi command
[...]

# smartctl --all -d scsi  /dev/sdd
smartctl 6.6 2016-05-31 r4324 [x86_64-linux-4.17.0-0.bpo.1-amd64] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Vendor:               Seagate
Product:              M3 Portable
Revision:             9300
Compliance:           SPC-4
User Capacity:        4 000 787 029 504 bytes [4,00 TB]
Logical block size:   512 bytes
Physical block size:  4096 bytes
Logical Unit id:      0x5000000000000001
Serial number:        NM13NXX4
Device type:          disk
Local Time is:        Mon Aug 20 21:08:31 2018 CEST
SMART support is:     Available - device has SMART capability.
SMART support is:     Disabled
Temperature Warning:  Disabled or Not Supported

=== START OF READ SMART DATA SECTION ===
SMART Health Status: OK
Current Drive Temperature:     0 C
Drive Trip Temperature:        0 C

Error Counter logging not supported

Device does not support Self Test logging

I hope this helps.

In case it matters, I'm using the Debian package and I'm not sure whether it contains the patch in https://www.smartmontools.org/ticket/875 but anyway, the issue is about sat vs. scsi.

# smartctl -V
smartctl 6.6 2016-05-31 r4324 [x86_64-linux-4.17.0-0.bpo.1-amd64] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

smartctl comes with ABSOLUTELY NO WARRANTY. This is free
software, and you are welcome to redistribute it under
the terms of the GNU General Public License; either
version 2, or (at your option) any later version.
See http://www.gnu.org for further details.

smartmontools release 6.6 dated 2016-05-07 at 11:17:46 UTC
smartmontools SVN rev 4324 dated 2016-05-31 at 20:45:50
smartmontools build host: x86_64-pc-linux-gnu
smartmontools build with: C++98, GCC 5.4.0 20160609
smartmontools configure arguments: '--prefix=/usr' '--build=x86_64-linux-gnu' '--host=x86_64-linux-gnu' '--sysconfdir=/etc' '--mandir=/usr/share/man' '--with-initscriptdir=no' '--docdir=/usr/share/doc/smartmontools' '--with-savestates=/var/lib/smartmontools/smartd.' '--with-attributelog=/var/lib/smartmontools/attrlog.' '--with-exampledir=/usr/share/doc/smartmontools/examples/' '--with-drivedbdir=/var/lib/smartmontools/drivedb' '--with-systemdsystemunitdir=/lib/systemd/system' '--with-smartdscriptdir=/usr/share/smartmontools' '--with-smartdplugindir=/etc/smartmontools/smartd_warning.d' '--with-systemdenvfile=/etc/default/smartmontools' '--with-selinux' 'build_alias=x86_64-linux-gnu' 'host_alias=x86_64-linux-gnu' 'CXXFLAGS=-g -O2 -fPIE -fstack-protector-strong -Wformat -Werror=format-security -fsigned-char -Wall -O2' 'LDFLAGS=-fPIE -pie -Wl,-z,relro -Wl,-z,now' 'CPPFLAGS=-Wdate-time -D_FORTIFY_SOURCE=2' 'CFLAGS=-g -O2 -fPIE -fstack-protector-strong -Wformat -Werror=format-security -fsigned-char -Wall -O2'

Change History (5)

comment:1 in reply to:  description Changed 11 months ago by Christian Franke

Keywords: uas linux added
Milestone: undecided
# lsusb
Bus 001 Device 012: ID 0bc2:61b7 Seagate RSS LLC

# smartctl --all -d sat  /dev/sdd
[...]
Read Device Identity failed: scsi error unsupported field in scsi command
...
# smartctl --all -d scsi  /dev/sdd
smartctl 6.6 2016-05-31 r4324 [x86_64-linux-4.17.0-0.bpo.1-amd64] (local build)

Is UAS transfer mode used ?
In this case the Linux kernel may block SAT ATA pass-through commands for devices with a Seagate USB Vendor ID. See USB wiki page and ticket #971 for details.

comment:2 Changed 11 months ago by smartjerome

I'm using Debian Stretch with a recent kernel (from stretch-backports IIRC), so that's probably it.

Sorry for not seeing this in the docs.

I guess there's not much I can do about it and I won't struggle anyway since this hard drive is rarely plugged in. It just happened to be plugged in yesterday when the daily check occurred.

Thanks for the hint. I suppose you can close this.

If you want, I can double check the kernel number and the UAS activation when I'm back home. (How do I check UAS is used?)

comment:3 Changed 11 months ago by Christian Franke

IIRC the kernel log reports something like ... kernel: scsi hostN: uas if UAS is used.

You may want to try kernel command line parameter usb_storage.quirks=0bc2:61b7:u to force USB (possibly only USB 2.0) mode or usb_storage.quirks=0bc2:61b7: to enable SAT ATA pass-through (own risk !-).

comment:4 Changed 11 months ago by smartjerome

Resolution: duplicate
Status: newclosed

I just realized I could access the machine from here. Indeed, the log says:

scsi host6: uas

Thanks for the tips. I'll probably just let it go. I don't really mind. I just hoped my feedback could help improve smartmontools, but it's not the case.

Closing as duplicate of https://www.smartmontools.org/ticket/971.

comment:5 Changed 11 months ago by Christian Franke

Milestone: undecided

Thanks for the feedback.

Note: See TracTickets for help on using tickets.